SpO2 MDK

Started by faya...@gmail.com in TMS320c55x8 years ago 2 replies

Dear all: I have purchased two cards one is TMDXEVM5505 ( C55xx ) main processor card, and other is SpO2 daughter card. I have...

Dear all: I have purchased two cards one is TMDXEVM5505 ( C55xx ) main processor card, and other is SpO2 daughter card. I have checked all example programs on processor card (without connecting SpO2 daughter card) e.g LCD, UART etc, The board is running well. But when i connect the daughter card and want to run any program (that was running well on standalone card), it ...


Connecting EVM to CCStudio v4.x

Started by faya...@gmail.com in TMS320c55x8 years ago 2 replies

Dear: I have purchased a TMS320C5505 EVM card which is supplied with CCStudio v3.3. I have downloaded and installed CCStudio v4.x. But...

Dear: I have purchased a TMS320C5505 EVM card which is supplied with CCStudio v3.3. I have downloaded and installed CCStudio v4.x. But now i can't interface my EVM with CCStudio v4.x. To interface the card, first to make a Target Configuration File. In making Target Configuration File, in the "Connection" box list there is no name for my EVM like "Spectrum Digital DSK-E...


High pass filtering 150hz

Started by habe...@tqautomation.com in TMS320c55x8 years ago 2 replies

hi, i am not able to block a 150 hz sine wave from my audio by using a high pass filter , i have obtained the filter coefficients from...

hi, i am not able to block a 150 hz sine wave from my audio by using a high pass filter , i have obtained the filter coefficients from LABVIEW. can anyone help me in this please. below is the code and the filter coefficients. short squelch_hpf_taps[SQUELCH_HPF_ORDER] = {6,2,3,3,2,2,1,0,-2,-4,-6,-7, -9,-11,-11,-12,-11,-10,-8,-4,0,5,11,16,22,27,31,34,35, 33, 30,23,15,4,-9, -22,-37,-51,-63,-73,...


Reg Interfacing Pre-Amp stage in C5505 USB stick

Started by "govind.sk85" in TMS320c55x8 years ago 1 reply

Hi All, I am having C5505USB_Kit. It has SJ1-3515-SMT, 5PJACK STEREO which is directly connected to TLVAIC3024 Codec. I want to add a...

Hi All, I am having C5505USB_Kit. It has SJ1-3515-SMT, 5PJACK STEREO which is directly connected to TLVAIC3024 Codec. I want to add a pre-amplification section before mic input goes to the line in of the codec. My Dobut: I want to add a pre-amplification section before the stereo jack itself. I am planning to use OPA335 .My condenser mic is P9955-ND.C5505USB_Kit has SJ1-3515 streo au...


Hex55 utility v4.3.6 -b option

Started by Vikram Ragukumar in TMS320c55x8 years ago 1 reply

Hello, I am trying to generate a binary file with boot table information using Hex55 v4.3.6. This file will be used for Flash boot of a C5510...

Hello, I am trying to generate a binary file with boot table information using Hex55 v4.3.6. This file will be used for Flash boot of a C5510 on a custom module. The memory width of the Flash being used on the module is 16 bits. This is the command line I am using hex55 -boot -v5510:2 -parallel16 -memwidth=16 -romwidth=16 -delay=10000 -e=_c_int00 -o=tmsc55xx.rom -b tmsc55xx.out ...


about GPT GPIO in C5505 EVM

Started by reyn...@hotmail.com in TMS320c55x8 years ago 1 reply

i configure all the interrupt in DSP/BIOS, i use timer to generate a sync signal output at gpio 11, so it works and the gpio output a sync signal...

i configure all the interrupt in DSP/BIOS, i use timer to generate a sync signal output at gpio 11, so it works and the gpio output a sync signal which is 10 ms 1 and 990 ms 0 until i stop it. i set gpio 10 as a input pin and let it trigerred a interrupt when it encount a rising edge. inside the interrupt routine i let variant count increas 1 when gpio is triggered.however, the gpio only trigger ...


c55x Code Snippets

Started by s_boucheryah in TMS320c55x8 years ago 1 reply

Hello, Just in case you didn't receive the announcement sent a couple of weeks ago, there is a new code sharing section on...

Hello, Just in case you didn't receive the announcement sent a couple of weeks ago, there is a new code sharing section on DSPRelated.com: http://www.dsprelated.com/code.php I am looking for individuals working with c55x DSPs who would have some code snippets to share with the community. Any code snippet has the potential to generate up to $250 in rewards to the author. Details of the rew...


Debugger does not halt at breakpoints

Started by Aditi Akula in TMS320c55x8 years ago 4 replies

Hi, This might sound like an old issue but here is my problem. I have set breakpoints in my code, and when I run the code, the...

Hi, This might sound like an old issue but here is my problem. I have set breakpoints in my code, and when I run the code, the debugger does not halt at any breakpoint (i have tried to set breakpoint even in Disassembly window just after _c_int00_). When I single-step through the code, the control enters main(), but when I run the code, the control just hangs (like goes to some other poi...


about Matlab generate C code which can be used in C5505

Started by reyn...@hotmail.com in TMS320c55x8 years ago 1 reply

Hey i found out that matlab can use simulink to build CCS project and it can optimize the code corresponding to the different DSP. Here is...

Hey i found out that matlab can use simulink to build CCS project and it can optimize the code corresponding to the different DSP. Here is the following question. i found out that matlab only support one chip which is C5510 DSK in C55XX series. however, i checked the driver for my TMS320C5505 EVM board, it is C5510 DSK. So, can i use matlab to generate CCS project for my TMS320C5505...


Connecting XDS510PP - Plus to CCS v3.3

Started by Aditi Akula in TMS320c55x8 years ago 2 replies

Hi, I am using CCS 3.3 and trying to connect my XDS510PP-Plus emulator. The emulator connection isgood, I verified it by running the...

Hi, I am using CCS 3.3 and trying to connect my XDS510PP-Plus emulator. The emulator connection isgood, I verified it by running the SDConfig utility by Spectrum Digital. It can do emulator rest, verify and Test (it gives 2 JTAG devices connected). When I open the CCS and try to connect the device (Debug -> Connect), I get the following error. Can somebody tell me how to get rid


Ask a Question to the DSPRelated community

To significantly increase your chances of receiving answers, please make sure to:

  1. Use a meaningful title
  2. Express your question clearly and well
  3. Do not use this forum to promote your product, service or business
  4. Write in clear, grammatical, correctly-spelled language
  5. Do not post content that violates a copyright