Problem: Connecting XDS510 to DM642

Started by "Nikolay A. Atanasov" in TMS320c6x15 years ago 5 replies

Hi everybody, I am new to dsp. I just received an XDS510 USB JTAG Emulator. I also have a Valde Systems VS1501 Board, which is based on the...

Hi everybody, I am new to dsp. I just received an XDS510 USB JTAG Emulator. I also have a Valde Systems VS1501 Board, which is based on the TMS320DM642 Processor. I installed the XDS drivers and went to CCSv3.3 Setup to Configure the board. I used the following configuration: C64xx Rev 1.1 XDS510-USB Board Driver Location: C:\CCStudio_v3.3\drivers\sdgo6400usb_11.dvr Diagnostic Utilit...


Booting from Flash vs Ram

Started by Jeremy Turner in TMS320c6x17 years ago 2 replies

Hi, Using DM642 on custom hardware, all hardware has been tested and verified (External SDRAM/FLASH etc). I have a program that...

Hi, Using DM642 on custom hardware, all hardware has been tested and verified (External SDRAM/FLASH etc). I have a program that runs correctly when loaded via JTAG into RAM and executed in CCS. However when the program is loaded from FLASH (via CE0 boot selection) it does not execute the same. I know the GEL file in CCS helps setup the


RES: Error connecting to the target:

Started by Ricardo Jose de Oliveira Carvalho in TMS320c6x15 years ago 2 replies

Michael, Thanks for the reply and tips. However I have been other error (powerless) when I try rum xdsprobe test on the DSK. It is connecting...

Michael, Thanks for the reply and tips. However I have been other error (powerless) when I try rum xdsprobe test on the DSK. It is connecting but the not rum xdsprob test? (no is clear for me) What voltage must be used on PIN 5 of the JTAG? I am using 3.3V and the DSK also. But the green led of the Gao XDS510 is OFF when I connect the DSK and ON when I connect the USB cable. Ricardo...


emulator + dsk

Started by sord...@hotmail.com in TMS320c6x16 years ago

Hi to all, I am going to post a question that may sound stupid, but I haven't been able to find out the answer. I have...

Hi to all, I am going to post a question that may sound stupid, but I haven't been able to find out the answer. I have configured correctly my dsk6713 and it works. I also have an XDS560 POD that is correctly connected to the PC. The question is: Is always necessary that the POD cable is connected to the DSK by the JTAG port?? Can the emulator works without this conection...


program not stable

Started by Yong Yang in TMS320c6x18 years ago 1 reply

Hi, all   I am using TI DM642 to develop a video codec. I need to communicate with PC to read/write encoded or...

Hi, all   I am using TI DM642 to develop a video codec. I need to communicate with PC to read/write encoded or decoded video stream via USB JTAG or TCP/IP Ethernet. Sometimes my program runs very well. But sometimes it does not run correctly, with problems


problem using xds560 usb emulator with c6424evm

Started by ahme...@yahoo.com in TMS320c6x14 years ago

hello everyone, i hv brought xds560 usb emulator from seed's and trying to connect it to evm6424,the problem is i hd no such file like "evm6424...

hello everyone, i hv brought xds560 usb emulator from seed's and trying to connect it to evm6424,the problem is i hd no such file like "evm6424 with xsd560usb emulator" in ccs-setup_v3.3 even when i hd installed the drivers,i hv some problem with embedded usb emulation ic so i cant use that feature i hv to use external jtag,kindly send me the steps which i should follow to run it regards, ahm...


Where to find instructions on EMIF configuration in GEL file

Started by William C Bonner in TMS320c6x15 years ago 4 replies

I have two very similar boards that I need to work with in my debugger with Spectrum Digital 510USB jtag device and CCS 3.1. The primary...

I have two very similar boards that I need to work with in my debugger with Spectrum Digital 510USB jtag device and CCS 3.1. The primary difference is that the V1 board uses a Samsung K6X8016T3B-TF55 chip providing 1MB of SRAM, and the V2 board uses a Samsung K4S561632E-TI75 chip providing 32MB of SDRAM. When I was given the V1 board, someone else set up my CCS environment for me. N...


Error connecting to the target:

Started by Ricardo Jose de Oliveira Carvalho in TMS320c6x15 years ago 4 replies

Hi, I am working with CCS 3.1 Firstly a used the XDS510, via JTAG, to connect a 6713DSK with successful. Now I am trying uses it to...

Hi, I am working with CCS 3.1 Firstly a used the XDS510, via JTAG, to connect a 6713DSK with successful. Now I am trying uses it to connect a new board with a 6713B DSP, and I have been a fatal error: Error connecting to the target: Error 0x80000200/-1070 Fatal Error during: OCS, Does somebody know what I have to do in order to solve this fatal error? Thanks. Ricardo Carvalho. ...


Question about C Runtime Routine CLOCK()

Started by William C Bonner in TMS320c6x17 years ago 2 replies

The following set of routines will compile just fine, and work when I'm connected to the board via JTAG, but without the external clock of my...

The following set of routines will compile just fine, and work when I'm connected to the board via JTAG, but without the external clock of my computer, they will not work correctly. How can I provide support for a real time clock in a DSP routine? Is there a simple way of building a timer tick system work? I need to keep track of real timer ticks for producing status messages to the...


Dsp to Host interrupt

Started by Jean-Francois SIMON in TMS320c6x17 years ago

Hello everyone! I've got a C64x problem :) I'm using the DM642 evaluation module as a PCI device in a PC running Linux. I'm trying to...

Hello everyone! I've got a C64x problem :) I'm using the DM642 evaluation module as a PCI device in a PC running Linux. I'm trying to generate an INT from the DSP to the host CPU, without any success so far. - I'm not using the JTAG interface - The DSP is in PCI boot mode, held in reset until the CPU host generates an interrupt. [this is working] - My code (dsp-side) boots. It init...


Parallel port interface

Started by Anonymous in TMS320c6x21 years ago 2 replies

Thank you all for your comments/inputs on my simple question about JTAG Emulation. I have another question, this time regarding ...

Thank you all for your comments/inputs on my simple question about JTAG Emulation. I have another question, this time regarding interfacing C6x01 and parallel port. Does anyone know how to interface a c6x01 DSP with a parallel port so that the two, host and DSP, can communicate (for


Gao USB XDS510 JTAG and C671x custom board

Started by "Simon E. Mushi" in TMS320c6x15 years ago 7 replies

Hi, I am using a GaoTek USB XDS510 with CCS 3.3 to do development on an Innovative Integration C6713 based board. After following setup...

Hi, I am using a GaoTek USB XDS510 with CCS 3.3 to do development on an Innovative Integration C6713 based board. After following setup instructions in the manual I get the following error in CCS starting up "Fatal Error during : OCS SC_ERR_OCS_PORT " What does this mean? I have run xdsprobe -f gao.cfg -p -x240 -r -v and the emulator claims to reset successfully. I have


TMS320F241 - Programmer to read/write

Started by Vitaly in TMS320c6x15 years ago

Hi, I am new here and I wanted to get some advice on what Programmer tool I should get that will be able to read/write to a TI...

Hi, I am new here and I wanted to get some advice on what Programmer tool I should get that will be able to read/write to a TI TMS320F241 (S1F35037PG) MCU? I have read about JTAG, but I am not sure how they will connect to the MCU. Please let me know what programmer you are currently using or know of one that would do a good job in reading and writing to TI MCU's Thank you


tms320c6701 and DSP bios

Started by faysal basci in TMS320c6x21 years ago 1 reply

I'm using c6701 based TI DSP board with JTAG and CCS ver2.0. I'm implementing FX-LMS algortihm;  to do real time debugging I'm...

I'm using c6701 based TI DSP board with JTAG and CCS ver2.0. I'm implementing FX-LMS algortihm;  to do real time debugging I'm trying to use DSP bios, however, I could not make my program run. I compil


DSP Booting through PCI

Started by an na in TMS320c6x18 years ago

I am working on DSP TMS 320C6415 chip on OKI evaluation board.I am writing a driver for that. We have a DSP application "pedi.out"...

I am working on DSP TMS 320C6415 chip on OKI evaluation board.I am writing a driver for that. We have a DSP application "pedi.out" which we load through JTAG and our test program internally calls some api's which internally callr driver routines and communicates with pedi.out.


Dsp to Host interrupt

Started by Jean-Francois SIMON in TMS320c6x17 years ago

Hello everyone! I've got a C64x problem :) I'm using the DM642 evaluation module as a PCI device in a PC running Linux. I'm trying to...

Hello everyone! I've got a C64x problem :) I'm using the DM642 evaluation module as a PCI device in a PC running Linux. I'm trying to generate an INT from the DSP to the host CPU, without any success so far. - I'm not using the JTAG interface - The DSP is in PCI boot mode, held in reset until the CPU host generates an interrupt. [this is working] - My code (dsp-side) boots. It initialize


Re: Error connecting to the target:

Started by Michael Dunn in TMS320c6x15 years ago

Ricardo, On 10/24/07, Ricardo Jose de Oliveira Carvalho wrote: > Hi, > > I am working with CCS 3.1 > > Firstly a used the XDS510,...

Ricardo, On 10/24/07, Ricardo Jose de Oliveira Carvalho wrote: > Hi, > > I am working with CCS 3.1 > > Firstly a used the XDS510, via JTAG, to connect a 6713DSK with successful= . > > Now I am trying uses it to connect a new board with a 6713B DSP, and I ha= ve been a fatal error: > > Error connecting to the target: Error 0x80000200/-1070 Fatal Error during= : OCS, >


TMS320C6701 Installation problems

Started by bhooshaniyer in TMS320c6x21 years ago 2 replies

Hi, Iam having few installation issues with my TMS320C6701 EVM board. The Board is a PCI slot card which goes into the mother...

Hi, Iam having few installation issues with my TMS320C6701 EVM board. The Board is a PCI slot card which goes into the mother board pci slot with an embedded jtag and not an external one. the issue is that,while the evm board is recognised and installed under emulation in devic


Booting problem of C6416T custom board

Started by shad...@yahoo.com in TMS320c6x14 years ago 2 replies

Hi. I've made a custom board using TMS320C6416T. Boot mode is host boot and the board has no HPI or PCI. When I connected the target...

Hi. I've made a custom board using TMS320C6416T. Boot mode is host boot and the board has no HPI or PCI. When I connected the target board to the CCS with XDS560 JTAG emulator, the following error message showed up: ------------------------------------------------------------------- Error connecting to the target: Error 0x80000240/-1147 Fatal Error during: Initialization, OCS, I...


Re: YUHUA XDS510 USB 2.0 Emulator - CCS Troubles

Started by scia...@inwind.it in TMS320c6x14 years ago

Hi again, I probably succeed to install correctly windows drivers and now device performs the reset via its tool, giving: "SEED USB2.0 XDS510...

Hi again, I probably succeed to install correctly windows drivers and now device performs the reset via its tool, giving: "SEED USB2.0 XDS510 CARD IS RESET, HARDWARE VERSION 1" I installed SEED drivers for CCS but now I've problems with CCS setup. I tried to connect TWO different boards, both with TMS320C6424 (C64x+) with direct JTAG connection. A board was working and the other is brand new t...