MEM_Alloc TI

Started by gie78 in comp.dsp16 years ago

Hi I posted a similar question a few days ago and got a good answer. But there is still one thing I don`t understand, maybe anybody could...

Hi I posted a similar question a few days ago and got a good answer. But there is still one thing I don`t understand, maybe anybody could help me again. My problem is still the segID. In some manuals TI writes the segID could be an integer or the memory segment name which you have defined in the DSP/BIOS Configuration Tool. Before you can use the segID identifier which is defined in t...


Stack Usage in CCS3

Started by Noway2 in comp.dsp16 years ago 3 replies

This morning I discovered something that was unexpected and I am hoping that someone with more knowledge of Code Composer can help me make...

This morning I discovered something that was unexpected and I am hoping that someone with more knowledge of Code Composer can help me make more sense of it. I am in the beginning stages of constructing an application that uses TI's dsp/BIOS. One of the routines makes a function call to another routine that displays a message on my 4x20 character display. The routine that calls the messag...


Overload printf function on C28 and DSP/BIOS

Started by TridenT in comp.dsp16 years ago 2 replies

Hi, i'm working on C2812 TEXAS DSP. I'd like to redefine a printf function to send strings to serial port instead of RTDX way. Have an...

Hi, i'm working on C2812 TEXAS DSP. I'd like to redefine a printf function to send strings to serial port instead of RTDX way. Have an idea ? I'd tried to redefined putchar or putc function, but it seems more complex. thx.


Anyone using TMS470 (ARM) toolset?

Started by Vladimir Vassilevsky in comp.dsp11 years ago 7 replies

Hello All, I have to use a TMS470 C/C++ compiler (TMS470 == ARM). The toolset wasn't my choice. The more I use it, the more nonsense I...

Hello All, I have to use a TMS470 C/C++ compiler (TMS470 == ARM). The toolset wasn't my choice. The more I use it, the more nonsense I discover and more doubts I have. Also, in theory there is TI DSP BIOS for ARM, but zero documentation. I suspect those tools are kinda unloved by TI, and I am the only one who had ever tried them, and the earlier I switch to something different, ...


Re: Asus A8N32-SLI Deluxe Backplate Questions.

Started by Michael A. Terrell in comp.dsp14 years ago

"??hw??f" wrote: > > Now then. They wouldnt "send a BIOS chip" since that isnt how you "fix" them. > If the chip can be re-flashed that...

"??hw??f" wrote: > > Now then. They wouldnt "send a BIOS chip" since that isnt how you "fix" them. > If the chip can be re-flashed that would be the way to go. > > Otherwise you replace the mobo since trying to de-solder a chip and replace it > would likely damage others in the process. s


malloc

Started by Simone Winkler in comp.dsp17 years ago 28 replies

Hello, I'm developping code for a C6713 DSP (actually it's the D.SignT-module with the C6713 on it). I'm trying to use malloc() but it...

Hello, I'm developping code for a C6713 DSP (actually it's the D.SignT-module with the C6713 on it). I'm trying to use malloc() but it doesn't seem to work. In the beginning I always received a null pointer. After a long while of searching my mistake I detected the section in the DSP/BIOS configuration for malloc(). I pointed it to SBSRAM and to SDRAM but both solutions didnt work - in...


TMS320DM642 startup problem

Started by steffenl in comp.dsp15 years ago 2 replies

Hi experts, we have an own video board based on a DM642 with flash, sdram, FPGA etc. Our application firmware works fine in the CCS 3.1 with...

Hi experts, we have an own video board based on a DM642 with flash, sdram, FPGA etc. Our application firmware works fine in the CCS 3.1 with XDS510USB emulator. We use DSP/BIOS. For standalone operation we wrote the first bootloader, based on the TI app notes and a second one for the more expensive loading of the application. After program the flash with these three parts and power-up the boa...


Questions regarding TI's DSP/BIOS on the 6713 Floating Point DSP

Started by Cyrus Yunker in comp.dsp17 years ago 1 reply

On 2004-06-03, Cyrus Yunker wrote: > I am trying to figure out if TI's 6713 DSP running at 225 MHz > is capable of performing the following...

On 2004-06-03, Cyrus Yunker wrote: > I am trying to figure out if TI's 6713 DSP running at 225 MHz > is capable of performing the following tasks. I've little > experience with DSP system design. > > I am interested in capturing 4 signals (> =16bits) at 400ksps > or better each. > > I'd then like to either stream that data to a computer (via > a USB interface pe


audio loop with c6713

Started by laurasscurtu in comp.dsp6 years ago

Hello, I am trying to do a simple audio loop (playpack loop) using only the McBSP with TI C6713. I must mention, I am new to the DSP world and...

Hello, I am trying to do a simple audio loop (playpack loop) using only the McBSP with TI C6713. I must mention, I am new to the DSP world and I would very much appreciate any help. I am working with DSP/BIOS and with CSL functions. So this is what I have done so far: I have programed 2 hardware interrupt functions, one for receive and one for transmit. I have connected my laptop to t...


Interfacing ADC_DSK6713 - Interrupt, Timing

Started by Martin J. in comp.dsp15 years ago

Dear Group, I am new in DSP processing and I am working on my diploma with DSK6713.I am solving the problem of interfacing DSK to 16-bit ADC...

Dear Group, I am new in DSP processing and I am working on my diploma with DSK6713.I am solving the problem of interfacing DSK to 16-bit ADC (AD7980). My problem is probably very basic so could anyone give some clue or link where to find more info? To set McBSPs I am using the BIOS. I want to interface ADC and DSK as described (CS\ Mode 3-wire with busy indicator). (Pull up ...


McASP Initialisation on C6713

Started by josi in comp.dsp14 years ago 2 replies

Hi, i have a problem with my McASP. I don't want use the DSP/BIOS so i configured the McASP with the CSL. On transmit/receive i hope to get...

Hi, i have a problem with my McASP. I don't want use the DSP/BIOS so i configured the McASP with the CSL. On transmit/receive i hope to get an interrupt, but i don't get one. The entries in the config structures are from an other project without the use of CSL. So i think they are correct. But i think my initialisation is bugy !? I hope you can help me. code: #include "mcasp.h" ...


question about dsp/bios configration

Started by Anonymous in comp.dsp15 years ago 1 reply

Hey ,everyone.I am studying the TIDSP.what i am using is the TMS302C5410.the software version is code composer studio 3.1.when i creat a new...

Hey ,everyone.I am studying the TIDSP.what i am using is the TMS302C5410.the software version is code composer studio 3.1.when i creat a new configration file,i find that the MCBSP setting has Advanced A,and Advanced B. i think that the mcbsp registers likes the SPCR1,SPCR2,RCR1,RCR2 and so on ,have been set in the figure .Need i set the Advanced A and Advanced B ? In the Advanced A ,there a...


TMS320VC5502 SDRAM boot

Started by itabhiyanta in comp.dsp15 years ago

Hi I have been working with a 5502EVM board and CCS3.1 as teh software tool. I want to place my code in SDRAM(and run it from there i.e....

Hi I have been working with a 5502EVM board and CCS3.1 as teh software tool. I want to place my code in SDRAM(and run it from there i.e. boot from flash, booloader copies code into SDRAM and places the entry point at start of sdram) and have been facing problems with the same. I create a new module in the DSP/BIOS GUI config and gave it's base 0x8000 and length as 0x200000. It seems to d...


CSS and Win2k

Started by Barry in comp.dsp18 years ago 3 replies

Hi, I got CSS to work on an NT machine first time, but I cant seem to get it working on a Windows 2000 machine. My first problem was with...

Hi, I got CSS to work on an NT machine first time, but I cant seem to get it working on a Windows 2000 machine. My first problem was with the ports (LPT1). Even when I change the BIOS to EPP 378H, I was still seeing ECP under the ports section of the device manager. Anyway, I deleted this driver and installed a parallel port driver and reconfigured the port, and now I see LPT1 under the...


.s55 (Code Composer Studio) problems

Started by Borrall Wonnell in comp.dsp15 years ago 1 reply

Hi all, TI's DSP/BIOS generates a cfg.s55 file. When I build my project, this file gets compiled. There are two problems: 1) I get a...

Hi all, TI's DSP/BIOS generates a cfg.s55 file. When I build my project, this file gets compiled. There are two problems: 1) I get a number of big, ugly remarks that I don't understand 2) It takes a long time to compile The remarks I get are all similar, and look something like this: "samplecfg.s55", REMARK at line 1118: [R5110] Instructions encoded in an


begginer's question - DMA of TI TMS320VC5510 dsk

Started by kruvytz in comp.dsp17 years ago 1 reply

Hello, This massage comes from two electrical enginnering students from Israel (please excuse our english). This is the problem: We're...

Hello, This massage comes from two electrical enginnering students from Israel (please excuse our english). This is the problem: We're trying to write a simple assembly program for TMS320VC5510 dsk, using CCS, not using DSP/BIOS and CSL. Only plain, direct, control registers modifications. The program is meant to make the DMA transfer the content of the count register (TIM0) of TIME...


Silly problem with Code Composer 3.1

Started by Anonymous in comp.dsp15 years ago 1 reply

OK, I have an extremely silly (almost embarrasing) problem with Code Composer 3.1. I'm going through some of the dsp/bios tutorials, and the...

OK, I have an extremely silly (almost embarrasing) problem with Code Composer 3.1. I'm going through some of the dsp/bios tutorials, and the first one has me opening the hello1 (hellobios) project and profiling it. Well, it tells me to check the appropriate box and then open the ranges tab, highlight the puts function and drag it over to the Ranges listing in the tab. Unfortunately, it doe...


Re: Asus A8N32-SLI Deluxe Backplate Questions.

Started by in comp.dsp14 years ago

Michael A. Terrell pinched out a steaming pile of : > "??hw??f" wrote: > > > > Now then. They wouldnt "send a BIOS chip" since that...

Michael A. Terrell pinched out a steaming pile of : > "??hw??f" wrote: > > > > Now then. They wouldnt "send a BIOS chip" since that isnt how you "fix" them. > > If the chip can be re-flashed that would be the way to go. > > > > Otherwise you replace the mobo since trying to de-solder a chip and replace it > > would likely dama


TI BIOS/CSL for 64xx/64x+ devices

Started by UglanceIcatch in comp.dsp15 years ago 6 replies

Greetings, I am seeking general ideas/opinions/guidance on software development for TI DSP devices, in particular, the newer fixed point...

Greetings, I am seeking general ideas/opinions/guidance on software development for TI DSP devices, in particular, the newer fixed point devices such as 6455. I do both algorithm development and implementation work. Most of my implementation work has been on simpler devices such as 5600, 96002, Sharc and 5510. I have been developing code for 6455 for about a month or so. Most of what I ...


DSP/BIOS: SWI from ISR

Started by Ajith in comp.dsp18 years ago 1 reply

Hi all, I am trying to post a software interrupt from an interrupt service routine of a hardware interrupt which comes every 7...

Hi all, I am trying to post a software interrupt from an interrupt service routine of a hardware interrupt which comes every 7 micro seconds. I post the SWI only when a particular condition is met in the isr. But after this SWI interrupt gets posted the program hangs...on halting i could see that the program is running on a self loop (a branch instruction to its location) called F...