Boxview debugger

Started by Anonymous in Freescale DSPs20 years ago 2 replies

Hi, Has anyone ever used BoxView Debugger from Domain Technologies? What are the advances or improvements does Boxview have...

Hi, Has anyone ever used BoxView Debugger from Domain Technologies? What are the advances or improvements does Boxview have over Debug-56K? Does anyone know any other debugger for Motorola DSP? Thanks in advance. Henry.


Re: Tasking debugger

Started by Graeme Fisher in Freescale DSPs17 years ago 7 replies

Hi, Regarding the Tasking Cross view debugger: Our company in looking into aquiring a CrossView debugger for the MOT56xxx...

Hi, Regarding the Tasking Cross view debugger: Our company in looking into aquiring a CrossView debugger for the MOT56xxx devices. Does anyone use one of these? If so, does it ship with hardware to connect to the target board or do we also have to buy extra hardwa


CW Debugger Stack Window Question

Started by Pete Becher in Freescale DSPs16 years ago 5 replies

Hi All, When I run my debugger the Stack window can show a lot of strange stuff. When the debugger stops at the start of main...

Hi All, When I run my debugger the Stack window can show a lot of strange stuff. When the debugger stops at the start of main there will be 2 to 8 functions and s before the normal archStart and Main functions. If I click on the other functions they will be at r


CodeWarrior 6.0 debugger problem.

Started by Roberto Bonacina in Freescale DSPs17 years ago

I'm going to describe a debugger problem that occured on CodeWarrior 6.0. I'm writing for DSP56F807 (internal flash). The...

I'm going to describe a debugger problem that occured on CodeWarrior 6.0. I'm writing for DSP56F807 (internal flash). The debugger problem can be divided in two parts: 1. In "M56800 Target" I set "Breakpoint mode" as "Automatic". I r


6.0 IDE debugger change default base from decimal to hex

Started by Corey, Rick in Freescale DSPs16 years ago 1 reply

Hi All Does anyone know how to change the default base for numeric display in the 6.0 CW IDE debugger windows from decimal to...

Hi All Does anyone know how to change the default base for numeric display in the 6.0 CW IDE debugger windows from decimal to hex? Edit | Preferences | Debugger | Display Settings | "Show values as decimal instead of hex" I've tried checking and un-check


execution speed using debug

Started by Joe McCarron in Freescale DSPs18 years ago 1 reply

Does using the debugger slow down execution speed of the program? I've programmed some interrupts to occur periodically (timer int ...

Does using the debugger slow down execution speed of the program? I've programmed some interrupts to occur periodically (timer int errupts) and would like to know, when running under the the debugger, if the periods are accurate. Thanks Joe


Metrowerks CodeWarrior Debugger Problem

Started by ljube20022000 in Freescale DSPs18 years ago 1 reply

Hi Everyone! I have a problem with CodeWarrior Debugger. It seems that my program stalls when I hit run from the menu. If I step...

Hi Everyone! I have a problem with CodeWarrior Debugger. It seems that my program stalls when I hit run from the menu. If I step over the code until while (1) loop and then hit run it works fine. Also, sometimes i just need to recompile(not making any changes)and then it starts worki


EVM debugger

Started by Hernan Dario Herrera in Freescale DSPs16 years ago

hi all.   I develop a small development system (D.S.) for the DSP56303PV100 and I want to know if there is any way to...

hi all.   I develop a small development system (D.S.) for the DSP56303PV100 and I want to know if there is any way to download a program to the D.S. through the DSP56303EVM debugger. We tried attaching the DSP56303 JTAG pins in the D.S. to the Command converter pins in


how to save stack trace without debugger in 568xx?

Started by t_karin1 in Freescale DSPs17 years ago 1 reply

One of the great features of the DSP 568xx is that its JTAG has FIFO dump of the last 5 jumps (jsr, braches, etc), so it is easier...

One of the great features of the DSP 568xx is that its JTAG has FIFO dump of the last 5 jumps (jsr, braches, etc), so it is easier in case of error to debug the sequence that lead to this error. However this can be done only when the debugger (CodeWarrior) is connected.


Codewarrior Debugger's Refusal to Refresh P Memory Viewing

Started by Jay Pochert in Freescale DSPs16 years ago

Hello, I'm currently working on creating a CAN based bootstrap loader for the DSPF80x family. The issue I have is that the...

Hello, I'm currently working on creating a CAN based bootstrap loader for the DSPF80x family. The issue I have is that the CodeWarrior Debugger (v6.1.2) refuses to refresh its presentation of any P Memory location unless I close the current debug session and relaunch a new one


56F8013 debug problem

Started by Carlo Concari in Freescale DSPs14 years ago

Hello group, I'm having a weird problem with a 56F8013 evaluation board. The problem is that on some computers, the debugger won't work; the...

Hello group, I'm having a weird problem with a 56F8013 evaluation board. The problem is that on some computers, the debugger won't work; the code can be run but execution won't stop neither on breakpoints nor by pressing the "Stop" button. Furthermore, it won't stop on application launch, even if this option is set in the Debugger Settings. We have tested on half a dozen different ...


56321 Hardware debugger problem

Started by ljube20022000 in Freescale DSPs16 years ago

Hi, I have a problem with Hardware Debugger tool ADS56300 ( Suite56 Development Tool Set). Every time when I load the file the...

Hi, I have a problem with Hardware Debugger tool ADS56300 ( Suite56 Development Tool Set). Every time when I load the file the source window only display the first line that looks like this: src:stereo_efcop.asm@0 pc=stereo_efcop.asm@0 pi:$400 section:global


Metrowerks Debugger SR I1 Mask Presented State

Started by jepochert in Freescale DSPs17 years ago 2 replies

Hello all, We have recently discovered that the Metrowerks Debugger wants to lie about the Status Register (SR) Interrupt 1...

Hello all, We have recently discovered that the Metrowerks Debugger wants to lie about the Status Register (SR) Interrupt 1 Mask (I1) state as presented within its Register Status Display window. Let me first qualify this a little. We are using the DSP56805 (rev F


AW: internal flash

Started by Bende Georg in Freescale DSPs17 years ago

You have to follow these steps: U set the target to "FLASH" in the IDE (now you should see "RAM") Go to the settings window,...

You have to follow these steps: U set the target to "FLASH" in the IDE (now you should see "RAM") Go to the settings window, select "Debugger/M56800 target settings"; if you select here "Always load program at debugger launch" then CW will do the


DSP56300 tools

Started by nilay_space in Freescale DSPs13 years ago 2 replies

can anybody tell me from where i can download DSP56300 assembler, debugger for free?

can anybody tell me from where i can download DSP56300 assembler, debugger for free?


assembly output

Started by Stuart Dejonge in Freescale DSPs18 years ago 1 reply

To all, For the DSP56F826 v. 5.0 tool, is there a way to view mixed C/Assembly for a given .c file, without actually...

To all, For the DSP56F826 v. 5.0 tool, is there a way to view mixed C/Assembly for a given .c file, without actually downloading to the debugger window? Thanks, Stuart


Info on Codewarrior USB Tap

Started by hgid...@instantel.com in Freescale DSPs15 years ago 2 replies

Hello: I am looking for a connection to a Freescale 56858 that will work with Codewarrior?s debugger. Currently we are talking to the...

Hello: I am looking for a connection to a Freescale 56858 that will work with Codewarrior?s debugger. Currently we are talking to the DSP56858EVM through its parallel port interface and would like faster download times. Eventually we will need to talk to our own board. Thanks.


Problem with CodeWarrior USB TAP

Started by x19er1 in Freescale DSPs15 years ago

I just purchased a Metrowerks USB TAP and am trying to use it with the DSP56852EVM dev. board. I have selected 56800E Local USBTAP ...

I just purchased a Metrowerks USB TAP and am trying to use it with the DSP56852EVM dev. board. I have selected 56800E Local USBTAP Connection in the Remote Debugging pane of my project settings. I know the PC is communicating to the TAP - the lights blink, etc. but I get the following error message when trying to start the debugger: CCSProtocolPlugin: CCS


DSP56367 HW debugger over JTAG?

Started by wdawson61 in Freescale DSPs17 years ago 1 reply

Hi. I'm trying to discern which (if any) IDE to get for Mot DSP56367 dev. I want to debug on my target HW (not an eval board)...

Hi. I'm trying to discern which (if any) IDE to get for Mot DSP56367 dev. I want to debug on my target HW (not an eval board) using the JTAG port. Does anyone know which product can do this? Thanks


Using newmicros' JTAG 14pin with Mot DSP563xx

Started by wdawson61 in Freescale DSPs17 years ago 5 replies

Has anyone successfully used the newmicro 14-pin JTAG -> parallel wiggler with the Mot Suite56 debugger (ads) ? ...

Has anyone successfully used the newmicro 14-pin JTAG -> parallel wiggler with the Mot Suite56 debugger (ads) ?