Using newmicros' JTAG 14pin with Mot DSP563xx

Started by wdawson61 in Freescale DSPs16 years ago 5 replies

Has anyone successfully used the newmicro 14-pin JTAG -> parallel wiggler with the Mot Suite56 debugger (ads) ? ...

Has anyone successfully used the newmicro 14-pin JTAG -> parallel wiggler with the Mot Suite56 debugger (ads) ?


DSP56858EVM bootloading

Started by gen_mak in Freescale DSPs15 years ago

Hi, How do I go about programing the DSP56858EVM board so that I can run a program without using the metroworks debugger? i've...

Hi, How do I go about programing the DSP56858EVM board so that I can run a program without using the metroworks debugger? i've managed to make a .s file but don't know how to get it on the board. I believe i have to program the flash memory somehow and then get it to boot from


CodeWarrior problem

Started by in Freescale DSPs17 years ago 1 reply

I have a following problem with CodeWarrior (V.5.XX) debugger: There is not possible to set a breakpoint to few function (at source...

I have a following problem with CodeWarrior (V.5.XX) debugger: There is not possible to set a breakpoint to few function (at source code begin) in some of project sources. (Please note that this is not a case when code is deadstipped because it is not used!). The minus ('-') charact


Code Warrior

Started by cwolfatwork in Freescale DSPs17 years ago 2 replies

I'm using Code Warrior, now, on a dsp56852, and, soon, on a dsp56858. So far all of my experience is on the 852, and it's not been...

I'm using Code Warrior, now, on a dsp56852, and, soon, on a dsp56858. So far all of my experience is on the 852, and it's not been a happy experience. The debugger is excruciateingly slow, and the compiler has to be checked all the time to see what code it's generating. So -- does an


How to make the application work without the help of debugger?

Started by Premkumar Chandramohan in Freescale DSPs16 years ago 1 reply

Hi everybody, I'm currently workin in development of a conrol system for BLDC motor using DSP56F805 processor. We're almost...

Hi everybody, I'm currently workin in development of a conrol system for BLDC motor using DSP56F805 processor. We're almost in the closing stage of the project. but still i didn't get any information about how to make the application boot from the processor......Still w


Problem with CodeWarrior USB TAP

Started by x19er1 in Freescale DSPs14 years ago

I just purchased a Metrowerks USB TAP and am trying to use it with the DSP56852EVM dev. board. I have selected 56800E Local USBTAP ...

I just purchased a Metrowerks USB TAP and am trying to use it with the DSP56852EVM dev. board. I have selected 56800E Local USBTAP Connection in the Remote Debugging pane of my project settings. I know the PC is communicating to the TAP - the lights blink, etc. but I get the following error message when trying to start the debugger: CCSProtocolPlugin: CCS


Breakpoint warning with 805EVM

Started by Bruno Tremblay in Freescale DSPs17 years ago 1 reply

Hi, I came back on a recent project with the DSP56F805EVM and when I tried to use the debugger I got this warning message: ...

Hi, I came back on a recent project with the DSP56F805EVM and when I tried to use the debugger I got this warning message: Breakpoint Warning Unable to set all the breakpoints requested. Some breakpoints may be disabled and will not stop the processor.


Deactivating Debugger

Started by hardeepgida in Freescale DSPs15 years ago 3 replies

Hi, I am using the DSP56858, which has no internal flash. It is using JTAG to communicate/program the board. However, I...

Hi, I am using the DSP56858, which has no internal flash. It is using JTAG to communicate/program the board. However, I need to unplug the JTAG after it has loaded my program into program RAM as I would like to do some current measurements. Everytime I unplug the JTA


stand alone

Started by zuffpasc in Freescale DSPs16 years ago 6 replies

Hello! Thank you for your previous answers!! Now my code is working with interrupts... but only with debugger because I've made a...

Hello! Thank you for your previous answers!! Now my code is working with interrupts... but only with debugger because I've made a "DSP 56800 EABI stationery project". Therefore my program can't work in "stand alone mode". How is the best way to make my progr


Remainder operator

Started by wmjidk9 in Freescale DSPs17 years ago 1 reply

I believe this should be a simple question, just have not been able to find it... when I use the remainder operator (%) in C...

I believe this should be a simple question, just have not been able to find it... when I use the remainder operator (%) in C code, and then step thru with Degubber (Metrowerks), the debugger wants me to show it where a file is (presumable to show me the source code for how thi


Inserting some delay

Started by Hardeep in Freescale DSPs14 years ago 1 reply

Hi, I am working with the Time of Day module in the DSP56858. This may be a real newbie question, but i'll explain the problem i'm...

Hi, I am working with the Time of Day module in the DSP56858. This may be a real newbie question, but i'll explain the problem i'm having...and I suppose it's more of a programming problem. In my mock program I set the current time, start the time to run and let the program spit out the time(as it progresses). When I use the debugger to step through


ADC driver and Interrupts (DSP56F805)

Started by Roger Flor in Freescale DSPs17 years ago 1 reply

Hello! I am using a DSP56F805 EVM. I am trying to run the ADC. I started by running the ADC application found in the...

Hello! I am using a DSP56F805 EVM. I am trying to run the ADC. I started by running the ADC application found in the applications folder that comes with SDK. When I ran the program, it halts upon entry to main because that is what is in the debugger settings. The stack pane of


DSP56311EVM: How do I get started?compiling and debugging C code

Started by chris_dsp in Freescale DSPs14 years ago

Hi, I have been given the DSP56311EVM to do a project on it. I need to write a program in C and execute it on the board using the Debugger....

Hi, I have been given the DSP56311EVM to do a project on it. I need to write a program in C and execute it on the board using the Debugger. I am using g563c to compile the code in "Windows Command Prompt". Any help on compiling and executing C code will be much appreciated. Thanks Christiaan


Assembler for DSP56F800

Started by cristianosostero in Freescale DSPs17 years ago

Hi all, I'm a new entry for this group. I,m trying to develop software for DSP56F800 in assembly. Codewarrior doesn't support a...

Hi all, I'm a new entry for this group. I,m trying to develop software for DSP56F800 in assembly. Codewarrior doesn't support a good debug feature for assembly software (no visibility for global variables, no symbol labels). Where can I find a debugger for my purpose? Is there


Running from flash without the debugger support (DSP56F827)

Started by atid2 in Freescale DSPs17 years ago 4 replies

Hi all, I'm having a hard time running my software directly from the flash of the DSP56F827. I'm using the serial bootloader...

Hi all, I'm having a hard time running my software directly from the flash of the DSP56F827. I'm using the serial bootloader to download the s-record file into the flash, and then it runs ok (even if I push the reset button). But the second I take out the electricity and


CW You Did It Again. CWerked the Memory Window in V5.1 for 56800.

Started by Pete Becher in Freescale DSPs16 years ago 8 replies

CodeWarrior, You did it again. The Memory window in the Debugger shows the bytes in reverse order. Is there an easy fix for...

CodeWarrior, You did it again. The Memory window in the Debugger shows the bytes in reverse order. Is there an easy fix for this reCWerk. (must be the new improved memory window mentioned in the spin-doctor drivel that you want us to read when installing v5.1) Pet


page erasing DFLASH ON DSP56F807

Started by Roberts Paul in Freescale DSPs17 years ago

I'm having difficulties page erasing the data flash unit. I've followed all steps for intelligent erasing on 5-15 of the...

I'm having difficulties page erasing the data flash unit. I've followed all steps for intelligent erasing on 5-15 of the User's manual. I can only mass erase with no problem, and get immediate feedback in the Metrowerks IDE's debugger. Addresses 0x2000 through 0x3fff only era


56F8322 debugging

Started by mickmonx in Freescale DSPs15 years ago 1 reply

Hello, I have downloaded a simple program (toggles a port pin - produced using the processor expert in code warrior)to a...

Hello, I have downloaded a simple program (toggles a port pin - produced using the processor expert in code warrior)to a 56F8322 via JTAG. when I try to step through the code the debugger seems happy enough but nothing happens to the port pin, after the first pass of the


Codewarrior / 56F8346EVM program running/debugging

Started by uwmechlab in Freescale DSPs16 years ago

I have a demo project that compiles properly and I'm tring to run it on my evm board to see the light turn off and on and I'm having...

I have a demo project that compiles properly and I'm tring to run it on my evm board to see the light turn off and on and I'm having trouble connecting to it from Codewarriors debugger... I get a command converter server error every time I click on "Debug" after making my p


DEMO56F8014 in stand alone operation

Started by rodr...@yahoo.com.br in Freescale DSPs12 years ago 1 reply

Hi, I'm trying to get the unit of the DEMO56F8014 EVM running in stand alone mode but I have had no success. Does anybody knows if the...

Hi, I'm trying to get the unit of the DEMO56F8014 EVM running in stand alone mode but I have had no success. Does anybody knows if the DEMO56F8014 EVM board can run in stand alone mode (without connection to the debugger in the CodeWarrior IDE) and if there is any document that treats this issue? Any direction will be appreciated. Thank you, Rodrigo