SDK 2.5 and 56f805 spi driver

Started by waynerob92780 in Freescale DSPs17 years ago

I'm trying to troubleshoot a compile error in the spi driver for the dsp56805evm. I compile the demo spi project OK ...

I'm trying to troubleshoot a compile error in the spi driver for the dsp56805evm. I compile the demo spi project OK "dps56805evm/nos/applications/spi". But i create my own test project using "embedded SDK stationary", copy the spi.c and configextram/appconfig.h fr


MC56F8322 SPI

Started by Syed Hasan Rizvi in Freescale DSPs15 years ago

Hi All, I am trying to interface '8322 DSP SPI port to a serial SPI device that takes four 16 bit words for each communication...

Hi All, I am trying to interface '8322 DSP SPI port to a serial SPI device that takes four 16 bit words for each communication cycle. The module aso requires the frame Slave Select bit (I am using SS of SPI port as an GPIO) to be toggled high and low after transmitting every 16 bit w


SPI soft

Started by max_mont in Freescale DSPs13 years ago 2 replies

Hi, I'm working on microcontroler freescale. And I have to develop a SPI interface via hardware IO. Have anyone already developed...

Hi, I'm working on microcontroler freescale. And I have to develop a SPI interface via hardware IO. Have anyone already developed this kind of SPI soft or is there anyone how could give me the chronograph of the 3 signals (MISO, MOSI and CLK)??? Thnaks in advance for your help.


Reading the SPI DataRxReg

Started by TA1T in Freescale DSPs16 years ago

I am inputting signals to the SPI module on my evm although I am not sure if the signals are reaching the data receive register...

I am inputting signals to the SPI module on my evm although I am not sure if the signals are reaching the data receive register correctly. My code initialises the SPI etc.. Slave = open(BSP_DEVICE_NAME_SPI_1, 0, &SpiParams); and then goes into this loo


FW: do Ineed to use a timer if using the SPI as a slave?

Started by Corey, Rick in Freescale DSPs16 years ago

-----Original Message----- From: Corey, Rick Sent: Monday, November 17, 2003 3:27 PM To: 'TA1T' Subject: RE: do Ineed to...

-----Original Message----- From: Corey, Rick Sent: Monday, November 17, 2003 3:27 PM To: 'TA1T' Subject: RE: do Ineed to use a timer if using the SPI as a slave? Hi I don't do the 56827, but if that is a SPI peripheral like the 803-807


Interrupt based data reception using SPI port doubt

Started by Nitin Yewale in Freescale DSPs16 years ago

Hi, I am using SPI port for data transmission in 56f826. I would like to know the difference between Spi0ReceiverFullError through...

Hi, I am using SPI port for data transmission in 56f826. I would like to know the difference between Spi0ReceiverFullError through pArchInterrupts and SPI_RX_INTERRUPT_ENABLE using ioctl function. I want to read data only when it arrives to SPI port i.e. interrupt bassed on RX.


SPI Communication between 56807

Started by stefan_schaeufele in Freescale DSPs15 years ago 8 replies

Hi, i would like to use the spi-module to communicate between DSP's. Normally there is one master and at least one slave DSP. The...

Hi, i would like to use the spi-module to communicate between DSP's. Normally there is one master and at least one slave DSP. The master will send two 32 bit values out of his spi-module (MOSI-pin) in 8-bit bundles. The slave who is interested in the master data, has to pull do


Explain timers use in ADC and SPI

Started by TA1T in Freescale DSPs16 years ago 1 reply

Hello, The Quad timer is required for the ADC module and the SPI module for generating sync pulses. However, could...

Hello, The Quad timer is required for the ADC module and the SPI module for generating sync pulses. However, could somebody please explain what the sync pulses do with regards to the ADC and the SPI modules. (Or how the quad timer is used in these ap


QSPI-to-SPI interface

Started by Corey, Rick in Freescale DSPs16 years ago 4 replies

Hi I am trying to connect a 5272 ColdFire QSPI peripheral to a DSP 56803 SPI peripheral. I can get the 5272 ColdFire QSPI to...

Hi I am trying to connect a 5272 ColdFire QSPI peripheral to a DSP 56803 SPI peripheral. I can get the 5272 ColdFire QSPI to loopback to itself fine. I can get the 56803 DSP SPI to loop back to itself fine. ISRs fire, data clocks back and forth, and it looks pretty clean on a


SPI for 8013

Started by haoyeshen in Freescale DSPs13 years ago 1 reply

I am trying to use 8013's SPI to send a 16 bits long info to a slave device. I am wondering if I could use SendChar command to do it. My...

I am trying to use 8013's SPI to send a 16 bits long info to a slave device. I am wondering if I could use SendChar command to do it. My concerns is that a Char is only 8 bits long. Can I use SendChar twice to achieve 16 bits long info? if not, how can I send 16 bits word by using SPI? Please help and thanks in advance.


DSP56858EVM - Can't get SPI boot to work.

Started by Louis Loving in Freescale DSPs16 years ago 3 replies

DSP56858EVM - Can't get SPI boot to work. Hello all, I am trying to execute the Second Stage SPI Bootloader Demo...

DSP56858EVM - Can't get SPI boot to work. Hello all, I am trying to execute the Second Stage SPI Bootloader Demo in the SDK using a D


SPI protocol with DSP563xx SCI port

Started by gusflit in Freescale DSPs14 years ago 1 reply

Hi to all, I already got some help from this forum a few months ago, maybe you can help me this time again. I need...

Hi to all, I already got some help from this forum a few months ago, maybe you can help me this time again. I need to communicate with the control port of an audio codec. The communication format is a standard SPI derivative, consisting of: - A gat


SPI receive

Started by cnnrgrdnr in Freescale DSPs16 years ago 1 reply

Hey, Does anybody have any working code that could receive SPI signals and send them to the pc for display. I have DSP56f827, ...

Hey, Does anybody have any working code that could receive SPI signals and send them to the pc for display. I have DSP56f827, SDK2.5, PC Master1.2. I would be very thankful if i could have a look at it as the code i have at the minute has lots of errors when i debug it.


SPI software

Started by bharath_sdpt in Freescale DSPs11 years ago

Hi All, i am developing SPI interface for DSC 56F805 using CodeWarrior IDE and Processor Expert. I am planning to use "SW_SPI" bean and use...

Hi All, i am developing SPI interface for DSC 56F805 using CodeWarrior IDE and Processor Expert. I am planning to use "SW_SPI" bean and use the methods "Send_Char", "Recv_Char". My question is, if i want to send a stream of 8 characters, can i use Send_Char continuously for eight times, or do i need to wait for some time between sucessive calls to "Send_Char". Please let me know w...


Need SPI code

Started by cnnrgrdnr in Freescale DSPs16 years ago

Does anyone have code to receive SPI signals via SPI1 on the 56f827 and then display the signals on PC Master? Thanks ...

Does anyone have code to receive SPI signals via SPI1 on the 56f827 and then display the signals on PC Master? Thanks


Can't get SPI to work

Started by mvl818 in Freescale DSPs16 years ago 1 reply

Hi, I'm trying to use the DAC on a 56F805 EVB and can't even get the SPI to work. I put an oscilloscope on spclk and then...

Hi, I'm trying to use the DAC on a 56F805 EVB and can't even get the SPI to work. I put an oscilloscope on spclk and then mosi and don't even get a single pulse. Here is some of the code I've tried: #define PEPUR 0x0FF0 /* GPIOE_BASE 0x0FF0 */ #


do Ineed to use a timer if using the SPI as a slave?

Started by TA1T in Freescale DSPs16 years ago 1 reply

I am using the SPI module on the dsp56f827 as a slave. It reads data on the MOSI but doesnt send anything back to the master on...

I am using the SPI module on the dsp56f827 as a slave. It reads data on the MOSI but doesnt send anything back to the master on the MISO.Do i need to use a quad timer at all. if so WHY,and what frequency should i set the timer to?


AW: Re: SPI Communication between 56807

Started by in Freescale DSPs16 years ago 1 reply

Hello Rick, Thanks for your help. I have found the error. The /SS-signal have to assigned as Peripherials (not as GPIO port). ...

Hello Rick, Thanks for your help. I have found the error. The /SS-signal have to assigned as Peripherials (not as GPIO port). Here the corrected slave setup: void spi_setup(void) { io.gpioe.per|=0x00F0; /* assign SCLK, MOSI & MISO, SS (GPIOE4-7) to SPI p


SPI and 56F8xx: Brain Dead?

Started by drjohn_online in Freescale DSPs15 years ago 1 reply

Hi, Has anyone ever got a 56F801 to work as an SPI slave? After weeks of trying, all I get are semi-random garbage chars in the...

Hi, Has anyone ever got a 56F801 to work as an SPI slave? After weeks of trying, all I get are semi-random garbage chars in the receive register after SPRF is set. I checked the chip errata but none described this problem. The scenario: 56F801 date code 0310


Output SPI commands from Timer Interrupt

Started by uwmechlab in Freescale DSPs15 years ago

Perhaps someone can give me some guidance here: On my 56F8346 EVM board I have an SPI D/A converter that requires 2 bytes sent...

Perhaps someone can give me some guidance here: On my 56F8346 EVM board I have an SPI D/A converter that requires 2 bytes sent out the SPI0 port to output a voltage. Since this is meant for a control system experiment I need to generate a time base to do this. I tried creating