Forums

C6713 simulator Error

Started by sank...@hotmail.com March 9, 2008
Hi everyone,

System: C6713 Device cycle accurate simulator ( CCS3.3)
-> Simulates C6713 processor
-> Supports L1P, L1D, L2 Cache, EDMA, QDMA, Timer(2), EMIF interfacing
with async and SDRAM Memory models, McBSP(2), interrupt selector.

My system: EDMA configured to acquire data in ping pong buffers mapped in external memory. A timer event is used to produce EDMA interrupt. In one sec ping pong slot, i intend to process the acquired data. processing involves fft, swt, filtering etc.

Note that except the ping pong buffer and constants, everthing is mapped in L2 (256k, no cache is configured)

As far as compilation goes, it is ok.

But while i run the code it gives the following errors:

Error: Memory Map Error: READ access by CPU to address 0x4e7dd240, (AHPIPCI Queue Space) which is NOT SUPPORTED in Simulator.
...
...
Error: Memory Map Error: READ access by CPU to address 0x3ef2d22c, which is RESERVED in Hardware.
...
...
Error: Illegal opcode (c47a0000) at pc = 0x00020260
...
...

>From the memory map it is apparnet that 256kbyte is not good enough for th
e system to run

MEMORY CONFIGURATION

name origin length used unused attr fill
---------------------- -------- --------- -------- -------- ---- --------
L2SRAM 00000000 00040000 00038b14 000074ec RWIX
EXTERNAL 80000000 80010000 000101e9 7ffffe17 RWIX

Can anyone give any suggestion what could be done. I have 8Mbyte of external memory and i have used only frction of it. What would be the best map i can do to use the external memory. Now i use the external memory to store my all constants as well. Pls note that i have once tried to map code (.text) in external memory. I got the same error. I do not know what is wrong.

any help would be appreciated. Thanks

Sankar
Check Out Industry's First Single-Chip, Multi-Format, Real-Time HD Video Transcoding Solution for Commercial & Consumer End Equipment: www.ti.com/dm6467