Forums

JTAG - CCS connection pbs

Started by Unknown February 11, 2005

Hi everybody,

Did anyone experienced connection problems with CCS 3.0?

My board is a third party board from Innovative Integration (Toro),
including the C6711 dsp.
I use the xds510pp-plus JTAG.

Actually, I can connect the emulator to the board with CCS v2.0, using
old drivers from Spectrum Digital.

I downloaded from Spectrum Digital the most recent driver releases for
CCS 3.0 (setupCCSC6000_v30101.ZIP), but I can't connect to the board
with the 3.0 version.
Please find below a detailed description of the pb.

Best regards, and thanks in advance for any answer.

Damien,
----------------------------------

Development Tools Support
* Host Computer System: PC
* Operating System: Windows2000- SP 1&2(same pb with XP and SP 1 to 4)
* Product: C6711 / Toro board from Innovative Integration

Here is the message I get from CCS after launching:
--------

Error connecting to the target:
Error 0x80000200/-180
Fatal Error during: OCS,
This error was generated by TI's USCIF driver.

SC_ERR_CTL_NO_TRG_POWER <-180>
The controller has detected a target power loss.
The user may have failed to turn-on or connect its source.

Sequence ID: 0
Error Code: -180
Error Class: 0x80000200
I/O Port = 240

Board Name: C671x XDS510 Emulator
Cpu Name: CPU_1

Abort: Close Code Composer Studio.
Retry: Try to connect to the target again.
Cancel: Remain disconnected from the target
Diagnostic: Run diagnostic utility.

-------

I checked everything with the SdConfig utility, and it seems OK:

Parallel port in the BIOS setup is et to SP8 mode, using IRQ 7 & Base IO
address = 0x378.

Power supply to the JTAG is OK, I checked 5.2 Volts.

Messages I get from SdConfig are:

-------

** Checking for available printer ports

$$ Printer port available at:
$$ EmuPortAddr=0x378
$$ EmuPortMode=SPP8
$$ EmuPortSpeed=0

** Checking for available USB ports
** Checking for a valid emulator/eZdsp

$$ You are connected to:
$$ EmuProductName=XDS510PP_PLUS
$$ EmuPortAddr=0x378
$$ EmuPortMode=SPP8
$$ ProductId
$$ ProductVersion

** Checking for a valid emulator/eZdsp

$$ You are connected to:
$$ EmuProductName=XDS510PP_PLUS
$$ EmuPortAddr=0x378
$$ EmuPortMode=SPP8
$$ ProductId
$$ ProductVersion ** Checking emulator/eZdsp scan connection

** Emulator Test **

$$ EmuProductName=XDS510PP_PLUS

$$ EmuPortAddr=0x378

$$ EmuPortMode=SPP8

$$ ProductId

$$ ProductVersion

** Emulator Scan Test

-- Found JTAG IR length of 46

-- Found 1 JTAG device(s) in the scan chain

** Emulator is reset

------

Last remark: I tried to configure the parallel port using different
modes (EPP, ECP), but the connection still fails.

If I change the I/O port in the CCS setup, I get the following error
report, so I guess this is not that.

------
Error connecting to the target:
Error 0x80000200/-118
Fatal Error during: OCS,
This error was generated by TI's USCIF driver.

SC_ERR_CTL_PORT <-118>
An invalid controller port value has been used.
Thus Unified-SCIF will not attempt to detect a controller
The standard 560 ports are 0x0, 0x1, 0x2 and 0x3.
The standard EVM ports are 0x0, 0x1, 0x2 and 0x3.
The standard DSK ports are 0x378, 0x278 and 0x3BC.
The standard 510 ports are 0x240, 0x280, 0x320 and 0x340. Sequence ID: 0
Error Code: -118
Error Class: 0x80000200
I/O Port = 378

Board Name: C62xx,C67xx XDS510 Emulator
Cpu Name: CPU_1

Abort: Close Code Composer Studio.
Retry: Try to connect to the target again.
Cancel: Remain disconnected from the target
Diagnostic: Run diagnostic utility.
------
--
Damien Courousse
PhD Student
Laboratoire ACROE-ICA
INPG, 46 avenue Felix Viallet
F-38031 Grenoble Cedex
Tel: 33 4 76 57 46 70
Fax: 33 4 76 57 48 89
http://acroe.imag.fr