Forums

Driver Problem in DM642 EVM

Started by Ramanan April 28, 2005
Dear Experts,

1. We recently acquired a DM642 Evaluation board through TI. Alongwith
the Board, we received an installation of CCS 2.2 and the DM642 EVM CD.
However, the DM642 EVM documentation mentions that the device drivers &
emulator drivers in the CD will work only with CCS v3.0 or higher.
Kindly confirm whether this is true.

2. Still wanting to try out the drivers, I installed all the drivers and
tried to build an example program 'client.pjt' that comes with the
Network Development Kit ( NDK). Here are the compilationerrors I got
when trying to build Client.pjt:

"c:\ti\plugins\bios\gconfgen" evmdm642.cdb
"evmdm642.cdb", line 1: error: Version 4.90.270 is not compatible with
this veion of BIOS. Please open this file in the Configuration Tool and
update.


"c:/ti/c6000/bios/include/csl_chiphal.h", line 187: fatal error: #error
NO CHIP DEFINED (use -dCHIP_XXXX where XXXX is chip number, i.e. 6201)

3. The bigger picture is I want to be able to run the Network
Development Kit and if you have any suggested alternatives, I would be
glad to hear them.

Thanks,
Ramanan


Hi,

ad 1/2. from my point of view, you should update to CCS 3.0 (build tools
5.0). If the examples that use DSP-Bios are stored under CCS 3.0, I think it
will be difficult to convert the .cdb file backwards to CCS 2.2 format. But
the best in that case would be to contact TI-support. They might also tell
you how you get the CCS 3.0

concerning the NO_CHIP_DEFINED: using CSL functions, you have to specify
with a #define which chip you are using. For the DM642, you have to add
-DCHIP_DM642
to the compiler options.

I think that the NDK is - similar to the DDK - a seperate package to be
installed seperately to CCS. You can download the DDK for example through
the 'update advisor' (in CCS go to menu Help -> Update Advisor -> Check for
Updates). well - I have never used the NDK, so I cant give you hints on
that..

bye,

Thomas

> Dear Experts,
>
> 1. We recently acquired a DM642 Evaluation board through TI. Alongwith
> the Board, we received an installation of CCS 2.2 and the DM642 EVM CD.
> However, the DM642 EVM documentation mentions that the device drivers &
> emulator drivers in the CD will work only with CCS v3.0 or higher.
> Kindly confirm whether this is true.
>
> 2. Still wanting to try out the drivers, I installed all the drivers and
> tried to build an example program 'client.pjt' that comes with the
> Network Development Kit ( NDK). Here are the compilationerrors I got
> when trying to build Client.pjt:
>
> "c:\ti\plugins\bios\gconfgen" evmdm642.cdb
> "evmdm642.cdb", line 1: error: Version 4.90.270 is not compatible with
> this veion of BIOS. Please open this file in the Configuration Tool and
> update.
>
>
> "c:/ti/c6000/bios/include/csl_chiphal.h", line 187: fatal error: #error
> NO CHIP DEFINED (use -dCHIP_XXXX where XXXX is chip number, i.e. 6201)
>
> 3. The bigger picture is I want to be able to run the Network
> Development Kit and if you have any suggested alternatives, I would be
> glad to hear them.
>
> Thanks,
> Ramanan

--
+++ Sparen beginnt mit GMX DSL: http://www.gmx.net/de/go/dsl