Forums

I2C initialize- help please - C6713 board

Started by varu...@bu.edu March 23, 2006
hi all
can you please tell me which regs I have to alter bits on to switch on the I2C module on the C6713

currently i have only made changes to the
I2CSTR
I2CMDR
on the I2C register list,

but are there other registers such as the HPI regs or some other peripheral reg that i have to make changes to before the I2C can be enabled

currently the slave device is a CMOS C3088 camera, while the C6713 DSP has been set as a MASTER XMIT to send data to the camera
unfortunately I am not sure why the correct changes are not being made to the camera... any ideas

sincerely,
Varun
Hi Varun,

have you read spru175a from TI website?

v...@bu.edu schrieb:
> hi all can you please tell me which regs I have to alter bits on to
> switch on the I2C module on the C6713
>
> currently i have only made changes to the I2CSTR I2CMDR on the I2C
> register list,
>
> but are there other registers such as the HPI regs or some other
> peripheral reg that i have to make changes to before the I2C can be
> enabled

I would suggest you use the CSL functions and set all I2C registers.
There comes an documentation with CCS.

> currently the slave device is a CMOS C3088 camera, while the C6713
> DSP has been set as a MASTER XMIT to send data to the camera
> unfortunately I am not sure why the correct changes are not being
> made to the camera... any ideas

Check this by an oscyloskope:

1st: Do yo have any signal on SCL or SDA?

2nd: Is the correct I2C addres on the bus?

3rd: Does the camera return an ACK after the address

4th: Are there other bytes after the address
HTH Gustl