Forums

JTAG emulator problem

Started by Giovanni Parodi October 4, 2006
Hello everybody, I use a XDS510PP plus JTAG emulator by Spectrum Digital, but the diagnostic give me the following erro:

** Emulator Scan Test

-- WriteVal1 0001, ReadVal1 ffff

-- WriteVal2 fffe, ReadVal2 ffff

-- WriteVal1 0002, ReadVal1 ffff

-- WriteVal2 fffd, ReadVal2 ffff

-- WriteVal1 0004, ReadVal1 ffff

-- WriteVal2 fffb, ReadVal2 ffff

-- WriteVal1 0008, ReadVal1 ffff

-- WriteVal2 fff7, ReadVal2 ffff

-- WriteVal1 0010, ReadVal1 ffff

-- WriteVal2 ffef, ReadVal2 ffff

-- WriteVal1 0020, ReadVal1 ffff

-- WriteVal2 ffdf, ReadVal2 ffff

-- WriteVal1 0040, ReadVal1 ffff

-- WriteVal2 ffbf, ReadVal2 ffff

-- WriteVal1 0080, ReadVal1 ffff

-- WriteVal2 ff7f, ReadVal2 ffff

-- WriteVal1 0100, ReadVal1 ffff

-- WriteVal2 feff, ReadVal2 ffff

-- WriteVal1 0200, ReadVal1 ffff

-- WriteVal2 fdff, ReadVal2 ffff

-- WriteVal1 0400, ReadVal1 ffff

-- WriteVal2 fbff, ReadVal2 ffff

-- WriteVal1 0800, ReadVal1 ffff

-- WriteVal2 f7ff, ReadVal2 ffff

-- WriteVal1 1000, ReadVal1 ffff

-- WriteVal2 efff, ReadVal2 ffff

-- WriteVal1 2000, ReadVal1 ffff

-- WriteVal2 dfff, ReadVal2 ffff

-- WriteVal1 4000, ReadVal1 ffff

-- WriteVal2 bfff, ReadVal2 ffff

ERROR >> ACT8990 register write/read test failed

Is there someone out of there that can help me solve this problem?
Thanks Gio

__________________________________________________
Do You Yahoo!?
Poco spazio e tanto spam? Yahoo! Mail ti protegge dallo spam e ti da tanto spazio gratuito per i tuoi file e i messaggi
http://mail.yahoo.it
Hello Gio,

I think that you have a problem :-)

The indication is that you have 1 of three problems - broken emulator, broken target board, or broken parallel port [or possibly misconfigured]. If you have more than 1 emulator and/or more than 1 target [of any type], try to identify which on is failing.
If you have only 1 of each, you will need to probe 2 JTAG signals at the connector.
1. When you run the diag, does TDI toggle?? this is an input
if yes, goto #2, else goto #4.
2. When you run the diag, does TDO toggle?? this is an output - it should be the same as the input.
if yes, continue, else there is a problem on the target. Check JTAG clock at the DSP if accessable.
3. You are getting data through the target but the emulator is not passing it on - problem with emulator [or parallel port].
4. When you connect the emulator, does TCK [JTAG clock] toggle?? this is the data clock
If yes, then the emulator [or parallel port] is bad, else something else on the emulator clock is bad.

The last line "ERROR >> ACT8990 register write/read test failed" indicates a problem with the emulator [could be parallel port].

mikedunn
----- Original Message ----
From: Giovanni Parodi
To: c...
Sent: Wednesday, October 4, 2006 12:15:15 PM
Subject: [c6x] JTAG emulator problem

Hello everybody, I use a XDS510PP plus JTAG emulator by Spectrum Digital, but the diagnostic give me the following erro:

** Emulator Scan Test

-- WriteVal1 0001, ReadVal1 ffff

-- WriteVal2 fffe, ReadVal2 ffff

-- WriteVal1 0002, ReadVal1 ffff

-- WriteVal2 fffd, ReadVal2 ffff

-- WriteVal1 0004, ReadVal1 ffff

-- WriteVal2 fffb, ReadVal2 ffff

-- WriteVal1 0008, ReadVal1 ffff

-- WriteVal2 fff7, ReadVal2 ffff

-- WriteVal1 0010, ReadVal1 ffff

-- WriteVal2 ffef, ReadVal2 ffff

-- WriteVal1 0020, ReadVal1 ffff

-- WriteVal2 ffdf, ReadVal2 ffff

-- WriteVal1 0040, ReadVal1 ffff

-- WriteVal2 ffbf, ReadVal2 ffff

-- WriteVal1 0080, ReadVal1 ffff

-- WriteVal2 ff7f, ReadVal2 ffff

-- WriteVal1 0100, ReadVal1 ffff

-- WriteVal2 feff, ReadVal2 ffff

-- WriteVal1 0200, ReadVal1 ffff

-- WriteVal2 fdff, ReadVal2 ffff

-- WriteVal1 0400, ReadVal1 ffff

-- WriteVal2 fbff, ReadVal2 ffff

-- WriteVal1 0800, ReadVal1 ffff

-- WriteVal2 f7ff, ReadVal2 ffff

-- WriteVal1 1000, ReadVal1 ffff

-- WriteVal2 efff, ReadVal2 ffff

-- WriteVal1 2000, ReadVal1 ffff

-- WriteVal2 dfff, ReadVal2 ffff

-- WriteVal1 4000, ReadVal1 ffff

-- WriteVal2 bfff, ReadVal2 ffff

ERROR >> ACT8990 register write/read test failed

Is there someone out of there that can help me solve this problem?
Thanks Gio

____________ _________ _________ _________ _________ __
Do You Yahoo!?
Poco spazio e tanto spam? Yahoo! Mail ti protegge dallo spam e ti da tanto spazio gratuito per i tuoi file e i messaggi
http://mail. yahoo.it

Hi performing checks that you suggested,it seems the JAG emulator is
broken :-(

Thanks for your help

Gio



Mike Dunn wrote:
cite="m...@web82814.mail.mud.yahoo.com"
type="cite">


Hello
Gio,

 

I
think that you have a problem  :-)

 

The
indication is that you have 1 of three problems - broken emulator,
broken target board, or broken parallel port [or possibly
misconfigured].  If you have more than 1 emulator and/or more than 1
target [of any type], try to identify which on is failing.

If
you have only 1 of each, you will need to probe 2 JTAG signals at the
connector.

1.
When you run the diag, does TDI toggle?? this is an input

if
yes, goto #2, else goto #4.

2.
When you run the diag, does TDO toggle?? this is an output - it should
be the same as the input.

if
yes, continue, else there is a problem on the target.  Check JTAG clock
at the DSP if accessable.

3. You
are getting data through the target but the emulator is not passing it
on - problem with emulator [or parallel port].

4. When
you connect the emulator, does TCK [JTAG clock] toggle?? this is the
data clock

If
yes, then the emulator [or parallel port] is bad, else something else
on the emulator clock is bad.

 

The
last line "ERROR >> ACT8990 register write/read test failed"
indicates a problem with the emulator [could be parallel port].

 

mikedunn




style="border-left: 2px solid rgb(16, 16, 255); margin: 5px 0px 5px 5px; padding-left: 5px; font-size: 12pt; font-family: times new roman,new york,times,serif;">-----
Original Message ----

From: Giovanni Parodi <g...@yahoo.it>

To: c...

Sent: Wednesday, October 4, 2006 12:15:15 PM

Subject: [c6x] JTAG emulator problem





Hello everybody, I use a XDS510PP plus JTAG emulator by Spectrum
Digital, but the diagnostic give me the following erro:



 ** Emulator Scan Test



   -- WriteVal1 0001, ReadVal1 ffff



   -- WriteVal2 fffe, ReadVal2 ffff



   -- WriteVal1 0002, ReadVal1 ffff



   -- WriteVal2 fffd, ReadVal2 ffff



   -- WriteVal1 0004, ReadVal1 ffff



   -- WriteVal2 fffb, ReadVal2 ffff



   -- WriteVal1 0008, ReadVal1 ffff



   -- WriteVal2 fff7, ReadVal2 ffff



   -- WriteVal1 0010, ReadVal1 ffff



   -- WriteVal2 ffef, ReadVal2 ffff



   -- WriteVal1 0020, ReadVal1 ffff



   -- WriteVal2 ffdf, ReadVal2 ffff



   -- WriteVal1 0040, ReadVal1 ffff



   -- WriteVal2 ffbf, ReadVal2 ffff



   -- WriteVal1 0080, ReadVal1 ffff



   -- WriteVal2 ff7f, ReadVal2 ffff



   -- WriteVal1 0100, ReadVal1 ffff



   -- WriteVal2 feff, ReadVal2 ffff



   -- WriteVal1 0200, ReadVal1 ffff



   -- WriteVal2 fdff, ReadVal2 ffff



   -- WriteVal1 0400, ReadVal1 ffff



   -- WriteVal2 fbff, ReadVal2 ffff



   -- WriteVal1 0800, ReadVal1 ffff



   -- WriteVal2 f7ff, ReadVal2 ffff



   -- WriteVal1 1000, ReadVal1 ffff



   -- WriteVal2 efff, ReadVal2 ffff



   -- WriteVal1 2000, ReadVal1 ffff



   -- WriteVal2 dfff, ReadVal2 ffff



   -- WriteVal1 4000, ReadVal1 ffff



   -- WriteVal2 bfff, ReadVal2 ffff



ERROR >> ACT8990 register write/read test failed



Is there someone out of there that can help me solve this problem?

Thanks Gio


____________ _________ _________ _________ _________ __

. yahoo.it







Gio,

If your emulator is not under warranty, you may want to open it up and do some probing - I am not sure if there is something like a fuse inside...

,mikedunn
----- Original Message ----
From: "g...@yahoo.it"
To: Mike Dunn
Cc: c...
Sent: Thursday, October 5, 2006 2:11:27 AM
Subject: Re: [c6x] JTAG emulator problem

Hi performing checks that you suggested,it seems the JAG emulator is broken :-(
Thanks for your help
Gio

Mike Dunn wrote:
Hello Gio,

I think that you have a problem :-)

The indication is that you have 1 of three problems - broken emulator, broken target board, or broken parallel port [or possibly misconfigured]. If you have more than 1 emulator and/or more than 1 target [of any type], try to identify which on is failing.
If you have only 1 of each, you will need to probe 2 JTAG signals at the connector.
1. When you run the diag, does TDI toggle?? this is an input
if yes, goto #2, else goto #4.
2. When you run the diag, does TDO toggle?? this is an output - it should be the same as the input.
if yes, continue, else there is a problem on the target. Check JTAG clock at the DSP if accessable.
3. You are getting data through the target but the emulator is not passing it on - problem with emulator [or parallel port].
4. When you connect the emulator, does TCK [JTAG clock] toggle?? this is the data clock
If yes, then the emulator [or parallel port] is bad, else something else on the emulator clock is bad.

The last line "ERROR >> ACT8990 register write/read test failed" indicates a problem with the emulator [could be parallel port].

mikedunn
----- Original Message ----
From: Giovanni Parodi
To: c...
Sent: Wednesday, October 4, 2006 12:15:15 PM
Subject: [c6x] JTAG emulator problem

Hello everybody, I use a XDS510PP plus JTAG emulator by Spectrum Digital, but the diagnostic give me the following erro:

** Emulator Scan Test

-- WriteVal1 0001, ReadVal1 ffff

-- WriteVal2 fffe, ReadVal2 ffff

-- WriteVal1 0002, ReadVal1 ffff

-- WriteVal2 fffd, ReadVal2 ffff

-- WriteVal1 0004, ReadVal1 ffff

-- WriteVal2 fffb, ReadVal2 ffff

-- WriteVal1 0008, ReadVal1 ffff

-- WriteVal2 fff7, ReadVal2 ffff

-- WriteVal1 0010, ReadVal1 ffff

-- WriteVal2 ffef, ReadVal2 ffff

-- WriteVal1 0020, ReadVal1 ffff

-- WriteVal2 ffdf, ReadVal2 ffff

-- WriteVal1 0040, ReadVal1 ffff

-- WriteVal2 ffbf, ReadVal2 ffff

-- WriteVal1 0080, ReadVal1 ffff

-- WriteVal2 ff7f, ReadVal2 ffff

-- WriteVal1 0100, ReadVal1 ffff

-- WriteVal2 feff, ReadVal2 ffff

-- WriteVal1 0200, ReadVal1 ffff

-- WriteVal2 fdff, ReadVal2 ffff

-- WriteVal1 0400, ReadVal1 ffff

-- WriteVal2 fbff, ReadVal2 ffff

-- WriteVal1 0800, ReadVal1 ffff

-- WriteVal2 f7ff, ReadVal2 ffff

-- WriteVal1 1000, ReadVal1 ffff

-- WriteVal2 efff, ReadVal2 ffff

-- WriteVal1 2000, ReadVal1 ffff

-- WriteVal2 dfff, ReadVal2 ffff

-- WriteVal1 4000, ReadVal1 ffff

-- WriteVal2 bfff, ReadVal2 ffff

ERROR >> ACT8990 register write/read test failed

Is there someone out of there that can help me solve this problem?
Thanks Gio

____________ _________ _________ _________ _________ __
Do You Yahoo!?
Poco spazio e tanto spam? Yahoo! Mail ti protegge dallo spam e ti da tanto spazio gratuito per i tuoi file e i messaggi
http://mail. yahoo.it