Forums

Question on the Simulator in Code Composer

Started by Egner, Uwe / R-VE October 12, 2000
Hi,
I would like to work with the simulator for TMS320F240.
What am I doing wrong? I'm working with Code Composer 4.10.
The following message appears on the screen.
"Trouble with Writing Target DSP memory
Error number -2052
Error address 40
Memory Map Error: Range"
Is there a FAQ-list for the simulator in Code Composer 4.10?
Thank you

> Kind Regards
> Uwe Egner





Hi

I have answered on this posting before, but when I use the reply
button the reply is not send to this group. So, instead I have send
this answer as a new posting to this group.
I have got a lot of response on some of my questions to this group
but only a few or none of the answers are shown here. So, it is
probably better to send the answer as a new posting instead of using
the reply function. There could be other persons which is interested
in the answers.

Answer:

You have to set the correct memory mapping (Option->Memory Map)in
Code Composer Studio, or else you will get an error when loading your
program.
I have experienced that I have to set values for all the memory
spaces. Even if my program does not use the IO-space the memory range
has to be set.
The best way is to include the memory map setting in a gel-file.

Best regards
Torgeir Jakobsen




Torgeir and everyone on this list,

a little clarification:

- When you want to reply to a group member only, you need to do a
regular reply.

- When you want your reply to be read by all the list, you have to do
a "reply all" from your mail client. Thanks
--- In , "Torgeir Jakobsen"
<torgeir.jakobsen@a...> wrote:
> Hi
>
> I have answered on this posting before, but when I use the reply
> button the reply is not send to this group. So, instead I have send
> this answer as a new posting to this group.
> I have got a lot of response on some of my questions to this group
> but only a few or none of the answers are shown here. So, it is
> probably better to send the answer as a new posting instead of
using
> the reply function. There could be other persons which is
interested
> in the answers.
>
> Answer:
>
> You have to set the correct memory mapping (Option->Memory Map)in
> Code Composer Studio, or else you will get an error when loading
your
> program.
> I have experienced that I have to set values for all the memory
> spaces. Even if my program does not use the IO-space the memory
range
> has to be set.
> The best way is to include the memory map setting in a gel-file.
>
> Best regards
> Torgeir Jakobsen