Forums

MCBSP UART not working after CSL upgrade ( sprc090 installation )

Started by gregor6713 November 2, 2006
I'm using CCS 2.21 to develop programs for TMS320C6713.

I was using CSL 2.31.00.2 and DDK 1.11. I was using files uartmd...;
uarthw_c6x1x_mcbsp ... to use MCBSP for serial communication with no
problem.

After upgrading CSL to 2.31.00.16 serial communication is no more working.

I checked differences between CSL source codes and there are minor
changes in MCBSP stuff except this one:

#define _MCBSP_XCR0_ADDR 0x01840010u ( CSL 2.31.00.02 )
#define _MCBSP_XCR0_ADDR 0x018C0010u ( CSL 2.31.00.16 )

It seems to be pretty important - the address of a register. But is it
possible they made such a obvious bug ?

Did anybody solve this problem before ?
Gregor-

> I'm using CCS 2.21 to develop programs for TMS320C6713.
>
> I was using CSL 2.31.00.2 and DDK 1.11. I was using files uartmd...;
> uarthw_c6x1x_mcbsp ... to use MCBSP for serial communication with no
> problem.
>
> After upgrading CSL to 2.31.00.16 serial communication is no more working.
>
> I checked differences between CSL source codes and there are minor
> changes in MCBSP stuff except this one:
>
> #define _MCBSP_XCR0_ADDR 0x01840010u ( CSL 2.31.00.02 )
> #define _MCBSP_XCR0_ADDR 0x018C0010u ( CSL 2.31.00.16 )
>
> It seems to be pretty important - the address of a register. But is it
> possible they made such a obvious bug ?

I've not noticed that one before, but I've seen others even worse coming
from DSP tools vendors. One time I found a macro that disabled interrupts
to make some register change and never re-enabled them. The DSP vendors
have engineers just like you and I trying to do their best, but also
sometimes making mistakes. So yes it's quite possible that CCS has such
"obvious bug".

Did you try changing the header file? What happens?

-Jeff