Forums

F240 Flash pbs using prg2xx

Started by Lotfi June 26, 2003
Hi

I am trying to flash a prog (im.out) between 1000h and 4000h on F240, on a
Technosoft IMMF240 device which use 0-1000h flash and don't want to
overwrite that zone.
My CMD is ok, because I can flash using technosoft prog via Serial...

But I want to use JTAG interface and the prg2xx prog
the test is fine but the writing gives errors :
API   Error 109, Processor Timeout
OTIS  Error 0

does anyone knows where is the pb ?

thank you for your help
please answear by mail :-)


----------------------------------------------------------------------------
----
Best regards
----------------------------------------------------------------------------
----
 PS here is the cmd line outputs :
c:\ti\specdig\prg2xx>btest

c:\ti\specdig\prg2xx>echo
Commande ECHO activ�e.

c:\ti\specdig\prg2xx>prg2xxw95 -p 378 -m 0x0006 -w 6 src\src\c2xx_btx.out
im.out


Spectrum Digital F2xx Flash Programmer Version 3.3

.
. Load Program (algo_file) to DSP
.
.
. Program Device
.

Finished

c:\ti\specdig\prg2xx>prog

c:\ti\specdig\prg2xx>Echo
Commande ECHO activ�e.

c:\ti\specdig\prg2xx>prg2xxw95 -p 378 -m 0x0006 -w 6 src\src\c2xx_bpX.out
im.out


Spectrum Digital F2xx Flash Programmer Version 3.3

.
. Load Program (algo_file) to DSP
.
API   Error 109, Processor Timeout
OTIS  Error 0

c:\ti\specdig\prg2xx>

----------------------------------------------------------------------------
----

thanks



any one there ???

thank you for your kind help

"Lotfi" <lbaghli(no_spam_at_all)@ifrance.com> a &#2013265929;crit dans le message news:
bdp0oh$mun$1@arcturus.ciril.fr...
> > Hi > > I am trying to flash a prog (im.out) between 1000h and 4000h on F240, on a > Technosoft IMMF240 device which use 0-1000h flash and don't want to > overwrite that zone. > My CMD is ok, because I can flash using technosoft prog via Serial... > > But I want to use JTAG interface and the prg2xx prog > the test is fine but the writing gives errors : > API Error 109, Processor Timeout > OTIS Error 0 > > does anyone knows where is the pb ? > > thank you for your help > please answear by mail :-) > > > --------------------------------------------------------------------------
--
> ---- > Best regards > --------------------------------------------------------------------------
--
> ---- > PS here is the cmd line outputs : > c:\ti\specdig\prg2xx>btest > > c:\ti\specdig\prg2xx>echo > Commande ECHO activ&#2013265929;e. > > c:\ti\specdig\prg2xx>prg2xxw95 -p 378 -m 0x0006 -w 6 src\src\c2xx_btx.out > im.out > > > Spectrum Digital F2xx Flash Programmer Version 3.3 > > . > . Load Program (algo_file) to DSP > . > . > . Program Device > . > > Finished > > c:\ti\specdig\prg2xx>prog > > c:\ti\specdig\prg2xx>Echo > Commande ECHO activ&#2013265929;e. > > c:\ti\specdig\prg2xx>prg2xxw95 -p 378 -m 0x0006 -w 6 src\src\c2xx_bpX.out > im.out > > > Spectrum Digital F2xx Flash Programmer Version 3.3 > > . > . Load Program (algo_file) to DSP > . > API Error 109, Processor Timeout > OTIS Error 0 > > c:\ti\specdig\prg2xx> > > --------------------------------------------------------------------------
--
> ---- > > thanks > > >