Forums

Analog Devices ADSP-21065L serial port trouble

Started by Zarin March 21, 2006
Hello, all,
I'm having a very strange occurrence with Analog Devices ADSP-21065L
SHARC DSP: the data come out of the serial port with the MSB of each
byte cleared, despite the fact that internally (and I checked this with
the VisualDSP++ debugger) the data have it in both states - sometimes
high, other times low.  This happens only on a handful of boards, and I
don't see any differences in the serial port control registers between
the "good" and the "bad" ones.  As I'm not familiar with hardware (I'm
a firmware engineer, not an electric engineer), I don't know where
exatly to start.  Does anyone have a similar experience?

Any suggestions and opinions are welcome.

Thanks in advance,
    Arkady.

Hi,

Zarin wrote:
> Hello, all, > I'm having a very strange occurrence with Analog Devices ADSP-21065L > SHARC DSP: the data come out of the serial port with the MSB of each > byte cleared, despite the fact that internally (and I checked this with > the VisualDSP++ debugger) the data have it in both states - sometimes > high, other times low. This happens only on a handful of boards, and I > don't see any differences in the serial port control registers between > the "good" and the "bad" ones. As I'm not familiar with hardware (I'm > a firmware engineer, not an electric engineer), I don't know where > exatly to start. Does anyone have a similar experience? > > Any suggestions and opinions are welcome. > > Thanks in advance, > Arkady.
Do all of your boards have the same revision of the DSP chip? Which one? JaaC