CCS does not show the Disassembled Assembly of the corresponding C Source in "Mixed Source/ASM" Mode

Started by karthikbg January 26, 2007
Hi,
I have enabled "Mixed Source/ASM" under the View Menu.
But, i am unable to view Both the C Code and the corresponding Assembly
instructions together . :( :( :( :( !!!!!
I am following the rules exactly as told in the CCS. Is there any bug
in this feature in CCS v3.1 ??

I do as per the below info from CCS Help, But i am still unable to view
Disassembled Instructions of each C statement within the sourcecode .

Pls find the Info from CCS below ( I follow this obediently ):
" To View Mixed C Source and Assembly Code, After loading a program
onto your target or simulator:
1)	Select View?Mixed Source/ASM. A check mark identifies when this
option is selected.
2)	Select Debug?Go Main.
The debugger starts executing the program and stops execution at
main(). The associated C source file is automatically displayed in an
Editor window. Notice that the disassembled instructions for each C
statement appear within the source code. Just as in the Disassembly
window, the location of the PC is highlighted in yellow. "

Why does CCS does not show the Assembly of the corresponding C Source ?
Kindly let me know some solutions.

Thx in advans,
Karthik Balaguru

"karthikbg" <karthik.balaguru@lntinfotech.com> wrote in 
news:1169819015.397937.251620@a75g2000cwd.googlegroups.com:

> Why does CCS does not show the Assembly of the corresponding C Source ? > Kindly let me know some solutions. > >
CCS maintains its own forum at ccsinfo.com. You'll probably get a faster answer there, and if you're getting into CCS, that's a resource you should know about anyway. -- Scott Reverse name to reply

On Jan 26, 7:03 pm, Scott Seidman <namdiestt...@mindspring.com> wrote:
> "karthikbg" <karthik.balag...@lntinfotech.com> wrote
innews:1169819015.397937.251620@a75g2000cwd.googlegroups.com:
> > > Why does CCS does not show the Assembly of the corresponding C Source ? > > Kindly let me know some solutions.CCS maintains its own forum at ccsinfo.com.
You'll probably get a faster
> answer there, and if you're getting into CCS, that's a resource you should > know about anyway. > > -- > Scott > Reverse name to reply
Thx for your reply. But, I refer to the CCS (Code Composer Studio) for DSP & OMAP(Dual-core) processors. www.ccsinfo.com refers to the CCS Compiler for PIC Microcontrollers. It is related to Embedded & DSP. I thought some people here could share your experiences w.r.t it and let me know some quick solutions and hence posted here. Anyhow, i will be forwarding my query to TI's CCS also. Thx in advans, Karthik Balaguru
karthikbg wrote:
> > On Jan 26, 7:03 pm, Scott Seidman <namdiestt...@mindspring.com> wrote: >> "karthikbg" <karthik.balag...@lntinfotech.com> wrote
innews:1169819015.397937.251620@a75g2000cwd.googlegroups.com:
>> >>> Why does CCS does not show the Assembly of the corresponding C Source ? >>> Kindly let me know some solutions.CCS maintains its own forum at ccsinfo.com.
You'll probably get a faster
>> answer there, and if you're getting into CCS, that's a resource you should >> know about anyway. >> >> -- >> Scott >> Reverse name to reply > > Thx for your reply. But, I refer to the CCS (Code Composer Studio) for > DSP & OMAP(Dual-core) processors. > www.ccsinfo.com refers to the CCS Compiler for PIC Microcontrollers. > > It is related to Embedded & DSP. I thought some people here could share > your experiences w.r.t it and let me know some quick solutions and > hence posted here. > Anyhow, i will be forwarding my query to TI's CCS also. > > Thx in advans, > Karthik Balaguru >
Open your pjt file in a text editor and copy and paste it back here.
> > Open your pjt file in a text editor and copy and paste it back here.-
This is the Pjt file in Txt Format w.r.t my Code Composer Studio Compiler/Linker Settings that is causing Debugging Problems. Any problem in the settings ?? ; Code Composer Project File, Version 2.0 (do not modify or remove this line) [Project Settings] ProjectName="Flash" ProjectDir="Z:\L1\L1Make\make\" ProjectType=Executable CPUFamily=TMS470R2X Tool="Compiler" Tool="CustomBuilder" Tool="Linker" Config="Debug" Config="Release" [Source Files] Source="..\..\..\..\tools\cgtools\lib\rts16e.lib" Source="..\..\L1\Src\Flash.c" Source="..\makelib\mylib.lib" Source="Flash.cmd" ["Compiler" Settings: "Debug"] Options=-g -q -o3 -fr"\L1\L1Make\make\out" -i"\L1\L1Make\make\h" - i"\L1\L1Make\make\flash" -d"HELENP1_EVM" -d"OMAP1510" -d"ARM" -me -mt ["Compiler" Settings: "Release"] Options=-q -o3 -fr"\L1\L1Make\make\out" -i"\L1\L1Make\make\h" - i"\L1\L1Make\make\flash" -d"HELENP1_EVM" -d"OMAP1510" -d"ARM" -me -mt ["Linker" Settings: "Debug"] Options=-q -c -esetup -m"\L1\L1Make\make\Flash.map" -o"\L1\L1Make\make \out\Flash.out" -x ["Linker" Settings: "Release"] Options=-q -c -esetup -m"\L1\L1Make\make\Flash.map" -o"\L1\L1Make\make \out\Flash.out" -x Any Ideas ?? Thx in advans, Karthik Balaguru

On Jan 29, 4:39 pm, "karthikbg" <karthik.balag...@lntinfotech.com> 
wrote:
> > > Open your pjt file in a text editor and copy and paste it back here.-This is
the Pjt file in Txt Format w.r.t my Code Composer Studio
> Compiler/Linker Settings that is causing Debugging Problems. Any > problem in the settings ?? > > ; Code Composer Project File, Version 2.0 (do not modify or remove > this line) > > [Project Settings] > ProjectName="Flash" > ProjectDir="Z:\L1\L1Make\make\" > ProjectType=Executable > CPUFamily=TMS470R2X > Tool="Compiler" > Tool="CustomBuilder" > Tool="Linker" > Config="Debug" > Config="Release" > > [Source Files] > Source="..\..\..\..\tools\cgtools\lib\rts16e.lib" > Source="..\..\L1\Src\Flash.c" > Source="..\makelib\mylib.lib" > Source="Flash.cmd" > > ["Compiler" Settings: "Debug"] > Options=-g -q -o3 -fr"\L1\L1Make\make\out" -i"\L1\L1Make\make\h" - > i"\L1\L1Make\make\flash" -d"HELENP1_EVM" -d"OMAP1510" -d"ARM" -me -mt > > ["Compiler" Settings: "Release"] > Options=-q -o3 -fr"\L1\L1Make\make\out" -i"\L1\L1Make\make\h" - > i"\L1\L1Make\make\flash" -d"HELENP1_EVM" -d"OMAP1510" -d"ARM" -me -mt > > ["Linker" Settings: "Debug"] > Options=-q -c -esetup -m"\L1\L1Make\make\Flash.map" -o"\L1\L1Make\make > \out\Flash.out" -x > > ["Linker" Settings: "Release"] > Options=-q -c -esetup -m"\L1\L1Make\make\Flash.map" -o"\L1\L1Make\make > \out\Flash.out" -x > > Any Ideas ?? > > Thx in advans, > Karthik Balaguru
On Jan 26, 1:23 pm, "karthikbg" <karthik.balag...@lntinfotech.com> wrote:
> On Jan 25, 9:26 pm, Roberto Waltman <use...@rwaltman.net> wrote: > > > > > > > Noway2 wrote: > > >karthikbg wrote: > > >>... > > >> 2) Further, I am placing the cursor in a correct/valid place say 'Run > > >> to Cursor', I get Error > > >> Message . The Error Message that is popped is as below : > > >> " Cursor is not on a valid line. Please move cursor to a valid line > > >> and try again. " > > >... > > > >Your "cursor is not on a valid line" message sounds a lot like you have > > >tried to place a breakpoint or something on a line that isn't code, such > > >as a compiler directive or comment.Also, (and more likely,) the cursor may be
at a valid source line for
> > which no assembly instructions have been generated. A good optimizing > > compiler can change the instruction order, combine several "C" level > > statements by using more powerful or complex assembly instructions, > > etc. > > > Roberto Waltman > > > [ Please reply to the group, > > return address is invalid ]I find that the Valid assembly instructions are
generated for the
> corresponding Valid C codes on which i haved placed a breakpoint. > I also came across some other clues in CCS manual . > When i place a break point in a C code, My CCS Debugger does not place > a breakpoint in the corresponding assembly code. > But, i find that i have enabled the Mixed View(C Source and Assembly). > Something is going wrong. > > Pls find the info that i got from CCS below: > > 1) "When you set a software breakpoint, the debugger highlights the > breakpointed > line in two ways: > a) It prefixes the statement with the character >. > b) It shows the line in a bolder or brighter font. (You can use > screen-customization > commands to change this highlighting method.) > If you set a breakpoint in the disassembly, the debugger also > highlights the > associated C statement. If you set a breakpoint in the C source, the > debugger > also highlights the associated statement in the disassembly. (If more > than one > assembly language statement is associated with a C statement, the > debugger > highlights the first of the associated assembly language statements.) " > > Something is going wrong :(:(:( ?? > > Thx in advans, > Karthik Balaguru- Hide quoted text -- Show quoted text -
Hi, Thx for your support . Finally, the problem got solved. I suspected that the problem might be mainly revolving around the Issue of symbols not getting displayed in the Symbol Browser Window in CCS (OMAP) . So, i went into analysing and debugging it. Once i made my .out file to get generated with the proper Symbol Info , i was able to view the Mixed Assembly & Source for my codes. I did find that my own Build File was overwritting the CCS settings/ Configurations and the .out file was not getting generated with the proper debug informations as the Build Options in Makefile were not properly gernerating the debug informations. Finally , i am able to view Files, Functions, and Globals of my .out file. I am also able to see all the things enabled in the 'Mixed Source/ASM" option under the dropdown menu of 'View" . The options of "Source step in" and "Source step over" are Enabled now along with "Assembly step in" and "Assembly step over" options. I am also able to do CStep now. Further, in the Breakpoints List View, i am able to see the breakpoints of both C Source and Assembly (Now, There are no Question Marks displayed in the place of address of Breakpoint). The great thing is , i am able to do 'Run to Cursor' and Step-in C files. Thx, Karthik Balaguru