Forums

TMS320C6416 DSK with CCS 3.1?

Started by Ralph A. Schmid, dk5ras February 24, 2007
Hi! 

For playing with DSPs at home I have a 6416DSK board, with the pseudo
JTAG emulation via USB and CCS 2.2 what came with the board.

Now I wanted to connect the board in the office, where we use CCS 3.x,
but I could not find a way to make this work via USB, only with the
real JTAG blackhawk emulator it is no problem at all. So what am I
doing wrong? Is there really no way into the board with CCS3.x and
USB? Would be easier to use USB, so I would not have to take apart the
whole setup I use for the "official" DSP work - I have only one
blackhawk available :)

Thank you for any help!

Ralph.
Ralph A. Schmid, dk5ras wrote:
> Hi! > > For playing with DSPs at home I have a 6416DSK board, with the pseudo > JTAG emulation via USB and CCS 2.2 what came with the board. > > Now I wanted to connect the board in the office, where we use CCS 3.x, > but I could not find a way to make this work via USB, only with the > real JTAG blackhawk emulator it is no problem at all. So what am I > doing wrong? Is there really no way into the board with CCS3.x and > USB? Would be easier to use USB, so I would not have to take apart the > whole setup I use for the "official" DSP work - I have only one > blackhawk available :) > > Thank you for any help! > > Ralph.
You can still make it work with the full version. You just need to have the driver for the on-board emulation. In the past it used to be that you needed a patch for the DSK. You may want to go to Update Advisor in CCS. Alternatively the more recent emulation drivers from Spectrum Digital actually include the DSK drivers. You may want to go to their website and upgrade to the CCS 3.3 Emulation Drivers. They are backward compatible with 3.1. Brad
Brad Griffis <bradgriffis@hotmail.com> wrote:

>> Ralph. > >You can still make it work with the full version. You just need to have >the driver for the on-board emulation. In the past it used to be that
Seems that the driver that comes woth the DSK does not work with later CC versions.
>you needed a patch for the DSK. You may want to go to Update Advisor in
I can try this tomorrow in the office, we will see.
>CCS. Alternatively the more recent emulation drivers from Spectrum >Digital actually include the DSK drivers. You may want to go to their >website and upgrade to the CCS 3.3 Emulation Drivers. They are backward >compatible with 3.1.
I will have a look, thank you for the tip!
>Brad
Ralph.
Brad Griffis <bradgriffis@hotmail.com> wrote:

>You may want to go to their >website and upgrade to the CCS 3.3 Emulation Drivers. They are backward >compatible with 3.1.
Great, that was ist! I had searched Ti with no particular result, but I had not thought of spectrumdigital, being the manufacturer of the board. Thank you very much, and with best regards Ralph.