Forums

CodeWarrior for DSP 5.1 Upgrade

Started by Litinas, Terry August 7, 2003
Hi,

I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for 56F807
development. I would like to upgrade to 5.1 and wonder what pitfalls there
might be. Are there any changes required to my current 5.05 projects or
code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it mandatory to
upgrade that to 3.0 also? If anybody has gone through this I would much
appreciate your experiences.

Thanks,

Terry Litinas
Project Engineer
ITW Balance Engineering
1731 Thorncroft
Troy, Mi. 48084

Ph: (248)643-2876
Fx: (248)643-2888



Hi Terry,
The CodeWarrior for DSP56800 v5.1 Provides new IDE, new Compiler and
improved debugger.
In the "New CodeWarrior IDE"
Docking windows now supported
Code completion now supported in editor
Improved configurable register view
Improved memory view
Improved resizable register view
Workspaces now supported

"New 56800 Compiler."
-Optimized to give better performance that version 5.0.4
-Improved verification and validation methodology gives most
reliable code "Improved debugger"
- Ability to debug any 56800 on a generic JTAG scan chain

I have positive experience myself after I upgrade CodeWarrior for
DSP56800 from v5.0 to v5.1. You can port your CodeWarrior v5.0.5
project to v5.1 directly. You may get some warning messages like:
"Warning: unsupported option:Enable bool support"
"Warning: unsupported option:Ebnable wchar_t Support"

Just uncheck two options "Enable bool Support" and "Enable wchar_t
Support" in the Target Settings Panels> Language Settings > C/C++
Language. You should solve these problem.

SDK 2.5 compatible with CodeWarrior v5.1, but I still recommend you
to upgrade SDK to 3.0. You can find SDK 3.0 at the following web
site, it's free:
http://e-www.motorola.com/webapp/sps/site/prod_summary.jsp?
code=MSW3SDK000AA&nodeIdM0ylgz6wYM959617836292 Hope it helps.
Regards
Hong

--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hi,
>
> I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
56F807
> development. I would like to upgrade to 5.1 and wonder what
pitfalls there
> might be. Are there any changes required to my current 5.05
projects or
> code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it mandatory
to
> upgrade that to 3.0 also? If anybody has gone through this I would
much
> appreciate your experiences.
>
> Thanks,
>
> Terry Litinas
> Project Engineer
> ITW Balance Engineering
> 1731 Thorncroft
> Troy, Mi. 48084
> tlitinas@i...
> Ph: (248)643-2876
> Fx: (248)643-2888





Hong,

Thank you for the information. Does this mean that 5.1 doesn't support the
bool data type?

Terry

-----Original Message-----
From: hong_dspnews [mailto:]
Sent: Thursday, August 07, 2003 10:55 AM
To:
Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade Hi Terry,
The CodeWarrior for DSP56800 v5.1 Provides new IDE, new Compiler and
improved debugger.
In the "New CodeWarrior IDE"
Docking windows now supported
Code completion now supported in editor
Improved configurable register view
Improved memory view
Improved resizable register view
Workspaces now supported

"New 56800 Compiler."
-Optimized to give better performance that version 5.0.4
-Improved verification and validation methodology gives most
reliable code "Improved debugger"
- Ability to debug any 56800 on a generic JTAG scan chain

I have positive experience myself after I upgrade CodeWarrior for
DSP56800 from v5.0 to v5.1. You can port your CodeWarrior v5.0.5
project to v5.1 directly. You may get some warning messages like:
"Warning: unsupported option:Enable bool support"
"Warning: unsupported option:Ebnable wchar_t Support"

Just uncheck two options "Enable bool Support" and "Enable wchar_t
Support" in the Target Settings Panels> Language Settings > C/C++
Language. You should solve these problem.

SDK 2.5 compatible with CodeWarrior v5.1, but I still recommend you
to upgrade SDK to 3.0. You can find SDK 3.0 at the following web
site, it's free:
http://e-www.motorola.com/webapp/sps/site/prod_summary.jsp?
code=MSW3SDK000AA&nodeIdM0ylgz6wYM959617836292 Hope it helps.
Regards
Hong

--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hi,
>
> I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
56F807
> development. I would like to upgrade to 5.1 and wonder what
pitfalls there
> might be. Are there any changes required to my current 5.05
projects or
> code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it mandatory
to
> upgrade that to 3.0 also? If anybody has gone through this I would
much
> appreciate your experiences.
>
> Thanks,
>
> Terry Litinas
> Project Engineer
> ITW Balance Engineering
> 1731 Thorncroft
> Troy, Mi. 48084
> tlitinas@i...
> Ph: (248)643-2876
> Fx: (248)643-2888
_____________________________________
Note: If you do a simple "reply" with your email client, only the author of
this message will receive your answer. You need to do a "reply all" if you
want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:

To Post:

To Leave:

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3 ">http://docs.yahoo.com/info/terms/



Terry,
You are right. CodeWarrior for DSP56800 doesn't support bool data
type, neither v5.0 nor 5.1. In reality these options are only
supported in C++ and since CodeWarrior for DSP doesn't support C++ so
these options have no affect. It is a bug that these options were
checked as default in v5.0, and this bug is fixed in v5.1.

Hope it helps.
Hong

--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hong,
>
> Thank you for the information. Does this mean that 5.1 doesn't
support the
> bool data type?
>
> Terry
>
> -----Original Message-----
> From: hong_dspnews [mailto:hong_dspnews@y...]
> Sent: Thursday, August 07, 2003 10:55 AM
> To:
> Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade > Hi Terry,
> The CodeWarrior for DSP56800 v5.1 Provides new IDE, new Compiler and
> improved debugger.
> In the "New CodeWarrior IDE"
> Docking windows now supported
> Code completion now supported in editor
> Improved configurable register view
> Improved memory view
> Improved resizable register view
> Workspaces now supported
>
> "New 56800 Compiler."
> -Optimized to give better performance that version 5.0.4
> -Improved verification and validation methodology gives most
> reliable code > "Improved debugger"
> - Ability to debug any 56800 on a generic JTAG scan chain
>
> I have positive experience myself after I upgrade CodeWarrior for
> DSP56800 from v5.0 to v5.1. You can port your CodeWarrior v5.0.5
> project to v5.1 directly. You may get some warning messages like:
> "Warning: unsupported option:Enable bool support"
> "Warning: unsupported option:Ebnable wchar_t Support"
>
> Just uncheck two options "Enable bool Support" and "Enable wchar_t
> Support" in the Target Settings Panels> Language Settings > C/C++
> Language. You should solve these problem.
>
> SDK 2.5 compatible with CodeWarrior v5.1, but I still recommend you
> to upgrade SDK to 3.0. You can find SDK 3.0 at the following web
> site, it's free:
> http://e-www.motorola.com/webapp/sps/site/prod_summary.jsp?
> code=MSW3SDK000AA&nodeIdM0ylgz6wYM959617836292 > Hope it helps.
> Regards
> Hong
>
> --- In , "Litinas, Terry" <tlitinas@i...>
> wrote:
> > Hi,
> >
> > I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
> 56F807
> > development. I would like to upgrade to 5.1 and wonder what
> pitfalls there
> > might be. Are there any changes required to my current 5.05
> projects or
> > code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it
mandatory
> to
> > upgrade that to 3.0 also? If anybody has gone through this I would
> much
> > appreciate your experiences.
> >
> > Thanks,
> >
> > Terry Litinas
> > Project Engineer
> > ITW Balance Engineering
> > 1731 Thorncroft
> > Troy, Mi. 48084
> > tlitinas@i...
> > Ph: (248)643-2876
> > Fx: (248)643-2888 >
> _____________________________________
> Note: If you do a simple "reply" with your email client, only the
author of
> this message will receive your answer. You need to do a "reply
all" if you
> want your answer to be distributed to the entire group.
>
> _____________________________________
> About this discussion group:
>
> To Join:
>
> To Post:
>
> To Leave:
>
> Archives: http://www.yahoogroups.com/group/motoroladsp
>
> More Groups: http://www.dsprelated.com/groups.php3 > ">http://docs.yahoo.com/info/terms/



Hong,

I had forgotten that the "bool" data type I use so often is actually just a
typedef for an int.

Thanks again,
Terry

-----Original Message-----
From: hong_dspnews [mailto:]
Sent: Thursday, August 07, 2003 1:54 PM
To:
Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade Terry,
You are right. CodeWarrior for DSP56800 doesn't support bool data
type, neither v5.0 nor 5.1. In reality these options are only
supported in C++ and since CodeWarrior for DSP doesn't support C++ so
these options have no affect. It is a bug that these options were
checked as default in v5.0, and this bug is fixed in v5.1.

Hope it helps.
Hong

--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hong,
>
> Thank you for the information. Does this mean that 5.1 doesn't
support the
> bool data type?
>
> Terry
>
> -----Original Message-----
> From: hong_dspnews [mailto:hong_dspnews@y...]
> Sent: Thursday, August 07, 2003 10:55 AM
> To:
> Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade > Hi Terry,
> The CodeWarrior for DSP56800 v5.1 Provides new IDE, new Compiler and
> improved debugger.
> In the "New CodeWarrior IDE"
> Docking windows now supported
> Code completion now supported in editor
> Improved configurable register view
> Improved memory view
> Improved resizable register view
> Workspaces now supported
>
> "New 56800 Compiler."
> -Optimized to give better performance that version 5.0.4
> -Improved verification and validation methodology gives most
> reliable code > "Improved debugger"
> - Ability to debug any 56800 on a generic JTAG scan chain
>
> I have positive experience myself after I upgrade CodeWarrior for
> DSP56800 from v5.0 to v5.1. You can port your CodeWarrior v5.0.5
> project to v5.1 directly. You may get some warning messages like:
> "Warning: unsupported option:Enable bool support"
> "Warning: unsupported option:Ebnable wchar_t Support"
>
> Just uncheck two options "Enable bool Support" and "Enable wchar_t
> Support" in the Target Settings Panels> Language Settings > C/C++
> Language. You should solve these problem.
>
> SDK 2.5 compatible with CodeWarrior v5.1, but I still recommend you
> to upgrade SDK to 3.0. You can find SDK 3.0 at the following web
> site, it's free:
> http://e-www.motorola.com/webapp/sps/site/prod_summary.jsp?
> code=MSW3SDK000AA&nodeIdM0ylgz6wYM959617836292 > Hope it helps.
> Regards
> Hong
>
> --- In , "Litinas, Terry" <tlitinas@i...>
> wrote:
> > Hi,
> >
> > I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
> 56F807
> > development. I would like to upgrade to 5.1 and wonder what
> pitfalls there
> > might be. Are there any changes required to my current 5.05
> projects or
> > code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it
mandatory
> to
> > upgrade that to 3.0 also? If anybody has gone through this I would
> much
> > appreciate your experiences.
> >
> > Thanks,
> >
> > Terry Litinas
> > Project Engineer
> > ITW Balance Engineering
> > 1731 Thorncroft
> > Troy, Mi. 48084
> > tlitinas@i...
> > Ph: (248)643-2876
> > Fx: (248)643-2888 >
> _____________________________________
> Note: If you do a simple "reply" with your email client, only the
author of
> this message will receive your answer. You need to do a "reply
all" if you
> want your answer to be distributed to the entire group.
>
> _____________________________________
> About this discussion group:
>
> To Join:
>
> To Post:
>
> To Leave:
>
> Archives: http://www.yahoogroups.com/group/motoroladsp
>
> More Groups: http://www.dsprelated.com/groups.php3 > ">http://docs.yahoo.com/info/terms/
_____________________________________
Note: If you do a simple "reply" with your email client, only the author of
this message will receive your answer. You need to do a "reply all" if you
want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:

To Post:

To Leave:

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3 ">http://docs.yahoo.com/info/terms/


Terry,
The best way to convert your SDK projects from one version to
the next is to create a new project using the new stationary and
drag your sources in there. So if you have a project that was
created with SDK v2.5 then when you get the 3.0SDK you would create
a new stationary using the same processor as you were using before
and drag your sources files from your previous project in.

When you get the new SDK 3.0 make sure that you get the right one.
There is a strip down version that only works with the DSP56800Demo
board and there is one that is a full version that will with all
processor.

Using SDK 2.5 with CodeWarrior for DSP v5.1 is not advised.

Regards,
Irene
--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hi,
>
> I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
56F807
> development. I would like to upgrade to 5.1 and wonder what
pitfalls there
> might be. Are there any changes required to my current 5.05
projects or
> code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it
mandatory to
> upgrade that to 3.0 also? If anybody has gone through this I would
much
> appreciate your experiences.
>
> Thanks,
>
> Terry Litinas
> Project Engineer
> ITW Balance Engineering
> 1731 Thorncroft
> Troy, Mi. 48084
> tlitinas@i...
> Ph: (248)643-2876
> Fx: (248)643-2888





Irene,

Thanks for the input. I'm a little nervous about the differences between SDK
2.5 and 3.0 since I have created some drivers for my hardware patterned
after the SDK 2.5 and wonder if they will still work OK with CodeWarrior
5.1. Sounds like to me that there's only one way to find out. I will try to
make some time next week to give it a try.

Thanks again,
Terry

-----Original Message-----
From: isierra95 [mailto:]
Sent: Thursday, August 07, 2003 5:33 PM
To:
Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade Terry,
The best way to convert your SDK projects from one version to
the next is to create a new project using the new stationary and
drag your sources in there. So if you have a project that was
created with SDK v2.5 then when you get the 3.0SDK you would create
a new stationary using the same processor as you were using before
and drag your sources files from your previous project in.

When you get the new SDK 3.0 make sure that you get the right one.
There is a strip down version that only works with the DSP56800Demo
board and there is one that is a full version that will with all
processor.

Using SDK 2.5 with CodeWarrior for DSP v5.1 is not advised.

Regards,
Irene
--- In , "Litinas, Terry" <tlitinas@i...>
wrote:
> Hi,
>
> I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
56F807
> development. I would like to upgrade to 5.1 and wonder what
pitfalls there
> might be. Are there any changes required to my current 5.05
projects or
> code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it
mandatory to
> upgrade that to 3.0 also? If anybody has gone through this I would
much
> appreciate your experiences.
>
> Thanks,
>
> Terry Litinas
> Project Engineer
> ITW Balance Engineering
> 1731 Thorncroft
> Troy, Mi. 48084
> tlitinas@i...
> Ph: (248)643-2876
> Fx: (248)643-2888
_____________________________________
Note: If you do a simple "reply" with your email client, only the author of
this message will receive your answer. You need to do a "reply all" if you
want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:

To Post:

To Leave:

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3 ">http://docs.yahoo.com/info/terms/



Terry -
 
I don't think that you will run into any issues with the upgrade. Their are not significant changes between SDK 2.5 and 3.0 just additions of new stationaries to support two new 56F800 devices and some additional telephony algorithims and drivers. The only change was all SDK projects (*.mcp) were converted to use CodeWarrior 5.1. Thanks.
 
- Bill
-----Original Message-----
From: Litinas, Terry [mailto:t...@itwbe.com]
Sent: Friday, August 08, 2003 4:31 AM
To: 'isierra95'
Cc: m...@yahoogroups.com
Subject: RE: [motoroladsp] Re: CodeWarrior for DSP 5.1 Upgrade

Irene,

Thanks for the input. I'm a little nervous about the differences between SDK
2.5 and 3.0 since I have created some drivers for my hardware patterned
after the SDK 2.5 and wonder if they will still work OK with CodeWarrior
5.1. Sounds like to me that there's only one way to find out. I will try to
make some time next week to give it a try.

Thanks again,
Terry

-----Original Message-----
From: isierra95 [mailto:i...@yahoo.com]
Sent: Thursday, August 07, 2003 5:33 PM
To: m...@yahoogroups.com
Subject: [motoroladsp] Re: CodeWarrior for DSP 5.1 UpgradeTerry,
       The best way to convert your SDK projects from one version to
the next is to create a new project using the new stationary and
drag your sources in there.  So if you have a project that was
created with SDK v2.5 then when you get the 3.0SDK you would create
a new stationary using the same processor as you were using before
and drag your sources files from your previous project in.

When you get the new SDK 3.0 make sure that you get the right one.
There is a strip down version that only works with the DSP56800Demo
board and there is one that is a full version that will with all
processor.

Using SDK 2.5 with CodeWarrior for DSP v5.1 is not advised.

Regards,
Irene
--- In m...@yahoogroups.com, "Litinas, Terry" <tlitinas@i...>
wrote:
> Hi,
>
> I am currently using CodeWarrior for DSP 5.05 with SDK 2.5 for
56F807
> development. I would like to upgrade to 5.1 and wonder what
pitfalls there
> might be. Are there any changes required to my current 5.05
projects or
> code? Is SDK 2.5 compatible with CodeWarrior 5.1 or is it
mandatory to
> upgrade that to 3.0 also? If anybody has gone through this I would
much
> appreciate your experiences.
>
> Thanks,
>
> Terry Litinas
> Project Engineer
> ITW Balance Engineering
> 1731 Thorncroft
> Troy, Mi. 48084
> tlitinas@i...
> Ph: (248)643-2876
> Fx: (248)643-2888
_____________________________________
Note: If you do a simple "reply" with your email client, only the author of
this message will receive your answer.  You need to do a "reply all" if you
want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:  m...@yahoogroups.com

To Post:  m...@yahoogroups.com

To Leave: m...@yahoogroups.com

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://docs.yahoo.com/info/terms/" target="_blank" rel="nofollow">http://www.dsprelated.com/groups.php3">http://docs.yahoo.com/info/terms/


_____________________________________
Note: If you do a simple "reply" with your email client, only the author of this message will receive your answer.  You need to do a "reply all" if you want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:  m...@yahoogroups.com

To Post:  m...@yahoogroups.com

To Leave: m...@yahoogroups.com

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3


">Yahoo! Terms of Service.




Me again.

I have tried to get data to come out of the TX0 pin(107) using the SCI
interface. I believe I have it setup properly but I would love it if
someone could check my settings just to be sure:

#define (WORD*)sci1br 0x0f10
#define (WORD*)sci1cr 0x0f11
#define (WORD*)sci1sr 0x0f12
#define (WORD*)sci1dr 0x0f13

*sci1br = 2083; //This is 2400 baud with a clock at 80Mhz - hopefully
*sci1cr = 0x00CC; now the code I execute to send data is pretty simple, maybe too simple?

result = *sci1sr;
*sci1dr = 0x0c; //First Byte of data. TDRE should be cleared, but it
//isn't. Page 12-9 #2 at top

while pin 15 in the sci1sr reg is 0
result=*sci1sr;

What else would I need to do to enable SCI1?



You may need to initialize the GPIO:
 
*(WORD*)(0x0fe3) |= 0x00c0;
-----Original Message-----
From: m...@bish.net [mailto:m...@bish.net]
Sent: Friday, August 08, 2003 12:27 PM
To: m...@yahoogroups.com
Subject: [motoroladsp] SCI1/ GPIOE + 56F805


Me again.

I have tried to get data to come out of the TX0 pin(107) using the SCI
interface.  I believe I have it setup properly but I would love it if
someone could check my settings just to be sure:

#define (WORD*)sci1br      0x0f10
#define (WORD*)sci1cr      0x0f11
#define (WORD*)sci1sr      0x0f12
#define (WORD*)sci1dr      0x0f13

*sci1br = 2083;      //This is 2400 baud with a clock at 80Mhz - hopefully
*sci1cr = 0x00CC;now the code I execute to send data is pretty simple, maybe too simple?

result = *sci1sr;
*sci1dr = 0x0c;      //First Byte of data. TDRE should be cleared, but it
            //isn't. Page 12-9 #2 at top

while pin 15 in the sci1sr reg is 0
      result=*sci1sr;

What else would I need to do to enable SCI1?


_____________________________________
Note: If you do a simple "reply" with your email client, only the author of this message will receive your answer.  You need to do a "reply all" if you want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:  m...@yahoogroups.com

To Post:  m...@yahoogroups.com

To Leave: m...@yahoogroups.com

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3


">Yahoo! Terms of Service.