Forums

How to make the application work without the help of debugger?

Started by Premkumar Chandramohan November 22, 2003

Hi everybody,

I'm currently workin in development of a conrol system for BLDC motor using
DSP56F805 processor. We're almost in the closing stage of the project. but still
i didn't get any information about how to make the application boot from the
processor......Still we make use of the debugger and we're currently in testing
phase of the project. once we tried to remove the JTAG after downloading the
application and we found the application was running successfully, and this too
we acheived after putting the jumper JG7 in the EVM. but then we tried resetting
the processor and we thought the application would start by itself by booting
from the processor itself. but it failed. I need to know how to make the
application run by itself once the EVM board is powered on.

Please understand the urgency of the problem and I'd be pleased if someone could
help me in this regard as soon as possible.

Waiting for the solution,

Prem

Yahoo! India Mobile: Ringtones, Wallpapers, Picture Messages and more.Download
now.



Prem,
 
Have you clicked on the 'Kill' button of the de-bugger before disconecting ? - this leaves the JTAG TAP port in the correct mode for automatically re-booting.
 
I had a similar problem with an 803 not booting itself up properly. I found out it was because my application code was over-writting the 1st 3 bytes of BootFlash (I was using it for non-volatile parameter storage in my program).
 
Best of luck,
 
Ian Duncan
CMA Electro-Hydraulic Engineers Pty. Ltd.
Hydraulic, Mechanical & Motion Control Consulting Engineers
P.O. Box 1095, 16-18 Doyle Avenue, Unanderra, N.S.W. 2526  AUSTRALIA
Mobile : 0411 055 113
Phone : 02 4272 6099
Fax     : 02 4272 6098
I...@c-mclellan.com.au
----- Original Message -----
From: Premkumar Chandramohan
To: m...@yahoogroups.com
Sent: Sunday, November 23, 2003 2:12 AM
Subject: [motoroladsp] How to make the application work without the help of debugger?


Hi everybody,

I'm currently workin in development of a conrol system for BLDC motor using DSP56F805 processor. We're almost in the closing stage of the project. but still i didn't get any information about how to make the application boot from the processor......Still we make use of the debugger and we're currently in testing phase of the project. once we tried to remove the JTAG after downloading the application and we found the application was running successfully, and this too we acheived after putting the jumper JG7 in the EVM. but then we tried resetting the processor and we thought the application would start by itself by booting from the processor itself. but it failed. I need to know how to make the application run by itself once the EVM board is powered on.

Please understand the urgency of the problem and I'd be pleased if someone could help me in this regard as soon as possible.

Waiting for the solution,

Prem

Yahoo! India Mobile: Ringtones, Wallpapers, Picture Messages and more.Download now.



_____________________________________
Note: If you do a simple "reply" with your email client, only the author of this message will receive your answer.  You need to do a "reply all" if you want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join:  m...@yahoogroups.com

To Post:  m...@yahoogroups.com

To Leave: m...@yahoogroups.com

Archives: http://www.yahoogroups.com/group/motoroladsp

More Groups: http://www.dsprelated.com/groups.php3


">Yahoo! Terms of Service.