Forums

56F8322 debugging

Started by mickmonx July 3, 2004
Hello,

I have downloaded a simple program (toggles a port pin - produced
using the processor expert in code warrior)to a 56F8322 via JTAG.
when I try to step through the code the debugger seems happy enough
but nothing happens to the port pin, after the first pass of the
code (it is set up as a continuous while loop) the debugger jumps to
another file in the program files -

M5600ESupport\msl\MSL_C\MSL_Common\Src\mem.c

Anybody know why this is happening? I would be grateful for any
suggestions.

When I change the CPU to an 8323 (with exactly the same set up) and
download using the JTAG it works perfectly.

Mike



It is hard to guess to what is going on from your brief description.
If you can zip and post your project, I will be glad to look at it
for you.

Leonard

--- In , "mickmonx" <michael@m...> wrote:
> Hello,
>
> I have downloaded a simple program (toggles a port pin - produced
> using the processor expert in code warrior)to a 56F8322 via JTAG.
> when I try to step through the code the debugger seems happy
enough
> but nothing happens to the port pin, after the first pass of the
> code (it is set up as a continuous while loop) the debugger jumps
to
> another file in the program files -
>
> M5600ESupport\msl\MSL_C\MSL_Common\Src\mem.c
>
> Anybody know why this is happening? I would be grateful for any
> suggestions.
>
> When I change the CPU to an 8323 (with exactly the same set up)
and
> download using the JTAG it works perfectly.
>
> Mike