Issue of fwrite() on C55x platform.

Started by LinL...@digital-control.com in TMS320c55x10 years ago 2 replies

Hi, I am working on C5510 DSK with CCS 3.3 and trying to read data from a file and write back data to another file. It seems that fwrite()...

Hi, I am working on C5510 DSK with CCS 3.3 and trying to read data from a file and write back data to another file. It seems that fwrite() is not working well on this platform. The write out file is always empty. My code was working well on C54x platform. Could anyone tell me the reason of that? Thanks a lot, Finspoo


Brand New TI DSP XDS510 emulator for SALE 99USD!

Started by franson in TMS320c55x10 years ago 1 reply

contact me!

contact me!


source code control in CCS

Started by Ashish Gupta in TMS320c55x10 years ago 2 replies

Hello, I need a souce code control software(SCC) which can be plugged with CCS. It is mentioned in CCS help menu that any Microsoft SCC can be...

Hello, I need a souce code control software(SCC) which can be plugged with CCS. It is mentioned in CCS help menu that any Microsoft SCC can be plugged with CCS3.3 and can be used for code version controlling. Can u pl suggest suitable SCC software. Ashish Gupta


How to call dsplib functions? linking error

Started by efei...@gmail.com in TMS320c55x10 years ago 1 reply

I'm using 5509 and CCS 3.1. All include search path and lib search path and head files have been added to my project. But when linking, there are...

I'm using 5509 and CCS 3.1. All include search path and lib search path and head files have been added to my project. But when linking, there are errors like this > > error: linking files for incompatible targets (library 'D:\CCStudio_v3.1\C5500\cgtools\lib\55xdsp.lib', member 'convol1.obj') Thanks.


Help with JTAG and XDS510 Emulator

Started by Sound Consulting in TMS320c55x10 years ago 2 replies

Can anyone suggest how I might debug a non-working XDS510 Emulator when connected to my board? This is my first TMS320 design, and I placed...

Can anyone suggest how I might debug a non-working XDS510 Emulator when connected to my board? This is my first TMS320 design, and I placed a JTAG header on the board along with proper pull-ups and clock routing. The XDS510 is an inexpensive third-party design XDS510-USB2.0 model. The TARGET LED lights up in blue when my unpowered board is attached, but applying power to the bo...


C5506.GEL missing?

Started by Sound Consulting in TMS320c55x10 years ago

Hi folks, I'm just getting started with a custom board that I designed, based on the TMS320VC5506 DSP. I have a JTAG port on the board, and...

Hi folks, I'm just getting started with a custom board that I designed, based on the TMS320VC5506 DSP. I have a JTAG port on the board, and an XDS510 USB 2.0 emulator. I just installed Code Composer Studio 3.3, the demo, and during setup I could not find any GEL files for the c5506. Can anyone tell me what I'm supposed to do here? Do I make my own C5506.GEL file? Has anyone w...


IIR filter coefficients in iircas5 dsplib

Started by s_da...@yahoo.com in TMS320c55x10 years ago 5 replies

Hi, I have a problem trying to implement an IIR filter with iircas5 function on an TI c55x. I have calculated the filter coefficients with...

Hi, I have a problem trying to implement an IIR filter with iircas5 function on an TI c55x. I have calculated the filter coefficients with matlab. My designed filter with MATLAB show 40dB attenation of input signal at 2000Hz while it is approximately 15dB in CCS with iircas5. Thanks.


Issue loading code on to the DSP.

Started by vivekjayadev in TMS320c55x10 years ago 7 replies

Hi, I am using CCS 3.3, XDS510usb emulator and the target board has C5510 DSPs. My setup has been working fine for the past few months....

Hi, I am using CCS 3.3, XDS510usb emulator and the target board has C5510 DSPs. My setup has been working fine for the past few months. Recently I have been having issues loading my code on to the DSPs. I get the following error: Trouble Writing Register: Error 0x00000004/-1024 Error during: Register, PTI_ERR_PREV_IROP_CMD Error Occured at 0x00000000 I thought it was an emulator/h...


Creating inilialized section for variables in C

Started by Ashish Gupta in TMS320c55x10 years ago 5 replies

hi, We are facing problem in developing hex file for the C code written on C55x processor in CCS. The variables such as arrays are defined...

hi, We are facing problem in developing hex file for the C code written on C55x processor in CCS. The variables such as arrays are defined globally and initialised then and there itself. These variables need to be put in hex file . When we generate the hex file using hex55 utility then these global variables don;t go into initialised section. Kindly guide us on how to put the initilased C va...


Programming boot EEPROM

Started by kas219 in TMS320c55x10 years ago 4 replies

I have run into a problem and I hope someone can help me out. I am working with a custom board that uses a 5509A DSP and an SPI EEPROM for code...

I have run into a problem and I hope someone can help me out. I am working with a custom board that uses a 5509A DSP and an SPI EEPROM for code storage.I have successfully tested my software using the JTAG interface and now it is time to load the code onto the EEPROM. The problem it, I don't know how to program the chip through the JTAG. I have tried "FlashBurn" but it is only set up to program...


Ask a Question to the DSPRelated community

To significantly increase your chances of receiving answers, please make sure to:

  1. Use a meaningful title
  2. Express your question clearly and well
  3. Do not use this forum to promote your product, service or business
  4. Write in clear, grammatical, correctly-spelled language
  5. Do not post content that violates a copyright