TI CCS Scripting Automation using Visual Basic or WSH

Started by robochaud in TMS320c55x13 years ago

Hi. I am trying to do some scripting using VB. To instantiate a link with CCS interface i tried: First Try: Set CCS =...

Hi. I am trying to do some scripting using VB. To instantiate a link with CCS interface i tried: First Try: Set CCS = WScript.CreateObject("CCS_Scripting_ComLib.CCS_Scripting") but i alwlays got an error: Could not locate automation class named "CCS_Scripting_ComLib.CCS_Scripting" ------------------------------------------------------------------ Second Try: Set CCS = WScript.Creat...


c5510 prototype board

Started by manohar in TMS320c55x17 years ago

Hello all, i want to install c5510 prototyoe board, with this they had given some patch for installing this board.i tried...

Hello all, i want to install c5510 prototyoe board, with this they had given some patch for installing this board.i tried with ccs version 1.2 , it is not adding the driver. I want to know whether ccs version2.0 is compulsory for this board or ccs 1.2


same binary, same DSK and different output depending on CCS Version

Started by robe...@dspsolutions.de in TMS320c55x13 years ago

Hi all, I compiled a binary with cg-tools 3.2.2 (from CCS V3.1). When I load and run this binary on a DSK C5510 hardware it works for CCS...

Hi all, I compiled a binary with cg-tools 3.2.2 (from CCS V3.1). When I load and run this binary on a DSK C5510 hardware it works for CCS 2.12.07 (which was shipped with the DSK board). But when I load the _same_ binary onto the same DSK board using CCS 3.1 -- there, after some frames of valid output suddenly the output gets erred. Has anyone seen something like this before


Re: Possible Bug in CCS-2.1 assembler???

Started by Suyog Deshpande in TMS320c55x17 years ago

Hello Gaurav: I have faced similar problems before....with both the versions (CCS 2.0/2.1) of TI tools :-( Suyog. ...

Hello Gaurav: I have faced similar problems before....with both the versions (CCS 2.0/2.1) of TI tools :-( Suyog. ----Original Message Follows---- From: "Gaurav" <> To: <> Subject: [c55x] Possible Bug in CCS-2.1 asse


Connecting XDS510PP - Plus to CCS v3.3

Started by Aditi Akula in TMS320c55x8 years ago 2 replies

Hi, I am using CCS 3.3 and trying to connect my XDS510PP-Plus emulator. The emulator connection isgood, I verified it by running the...

Hi, I am using CCS 3.3 and trying to connect my XDS510PP-Plus emulator. The emulator connection isgood, I verified it by running the SDConfig utility by Spectrum Digital. It can do emulator rest, verify and Test (it gives 2 JTAG devices connected). When I open the CCS and try to connect the device (Debug -> Connect), I get the following error. Can somebody tell me how to get rid


Hardware requirements to download the CCS code on DSP

Started by jyot...@yahoo.in in TMS320c55x10 years ago 9 replies

Hi,i m building a simple board for an audio application using C5509A.There will also be a codec and voltage regulator on the board.I need to know...

Hi,i m building a simple board for an audio application using C5509A.There will also be a codec and voltage regulator on the board.I need to know how to download the CCS code on the processor.What additional hardware is needed on the board to download the CCS program onto the DSP?


source code control in CCS

Started by Ashish Gupta in TMS320c55x10 years ago 2 replies

Hello, I need a souce code control software(SCC) which can be plugged with CCS. It is mentioned in CCS help menu that any Microsoft SCC can be...

Hello, I need a souce code control software(SCC) which can be plugged with CCS. It is mentioned in CCS help menu that any Microsoft SCC can be plugged with CCS3.3 and can be used for code version controlling. Can u pl suggest suitable SCC software. Ashish Gupta


Re: Initializing GPIO through .cdb file in CCS2.21

Started by bruc...@cyberonics.com in TMS320c55x14 years ago

Hi, I'm curious if you ever found a resolution to this problem. I am experiencing the same problem in both CCS 2.21 and CCS 3.1 with a C5509...

Hi, I'm curious if you ever found a resolution to this problem. I am experiencing the same problem in both CCS 2.21 and CCS 3.1 with a C5509 and C5507 build.


Re: [code-comp] CCS scripting (perl) & CCS GEL "scripting" problems

Started by Jeff Brower in TMS320c55x15 years ago

Dan- Just a general comment, but why are you using CCS/JTAG for production testing? Do you have a simple HPI connector on your...

Dan- Just a general comment, but why are you using CCS/JTAG for production testing? Do you have a simple HPI connector on your board? All of the full functional test groups we've worked with (Cisco, Sanmina, Nortel, etc) use HPI interface. JTAG tends to be slow, you hav


debug in CCS

Started by iewil2000 in TMS320c55x11 years ago 5 replies

Dear group, Is there any way to be notified by CCS in debug mode when a particular address is written? One of my buffer seems be polluted by...

Dear group, Is there any way to be notified by CCS in debug mode when a particular address is written? One of my buffer seems be polluted by other data, but I don't know which line of code did it and in what circumstances. Thanks, Wei


CCS 3.1.0 crashes when typing ")." in a comment

Started by joeblogss84 in TMS320c55x12 years ago 2 replies

This one is odd. When I type bracket followed by a period (that is ")." but without the quotes) CCS just exits immediately; no files are...

This one is odd. When I type bracket followed by a period (that is ")." but without the quotes) CCS just exits immediately; no files are saved, no access violation or any warning like that, it just instantly disappears (both the editor window and the parallel debug manager). It seems to only happen when I am writing within a comment (block or single line and only when the ")" does not fo...


Developing a DSP Algorithm

Started by Prakhar Vig in TMS320c55x13 years ago

Hi All, I am working on DSP algorithm as I am new to this I tried to experiment something on CCS. But facing some problems with it. I am...

Hi All, I am working on DSP algorithm as I am new to this I tried to experiment something on CCS. But facing some problems with it. I am planning to work on image processing side. Before, writing any algorithm I thought of understading the libraries present in the imglib and dsplib folders in CCS. I also tried to understand the examples like h


USB oddity

Started by ch1n00k71 in TMS320c55x16 years ago 1 reply

Hi Group. I've been developing USB code for 5509/5509A using CSL and CCS 2.20.00. So far everything worked fine. Recently I...

Hi Group. I've been developing USB code for 5509/5509A using CSL and CCS 2.20.00. So far everything worked fine. Recently I upgraded to CCS 2.20.18 and started to observe USB problems for interrupt driven implementation. Setup A 1) Cold reset. 2) Loadi


CCS 3.1 error

Started by p4pr...@gmail.com in TMS320c55x11 years ago 1 reply

Hi, I am working CCS v3.1. in tat i wan to do malloc of a simple array and i am getting the following linker error. undefined ...

Hi, I am working CCS v3.1. in tat i wan to do malloc of a simple array and i am getting the following linker error. undefined first referenced symbol in file --------- ---------------- _malloc C:\Projects\AMSEC\AMSECTI\TIEx\mallc\Debug\mallc.obj > > error: symbol referencing errors -


printf() behaviour in CCS1.2 for C55x

Started by Sheen Ross in TMS320c55x18 years ago

Hello Members, I recently started some Channel Coding exercise. I am facing a strange problem in CCS 1.2 for C55x. I wrote some...

Hello Members, I recently started some Channel Coding exercise. I am facing a strange problem in CCS 1.2 for C55x. I wrote some code in MS VC and ported it to CCS. All errors and warning's were removed. It executes correctly but is unable to execute printf statements. It


questions about head file including in ccs

Started by Randy Hoo in TMS320c55x11 years ago

I am using CCS with 5510DSK on one project and I met a problem. I find out that some examples can not include the head for the support library...

I am using CCS with 5510DSK on one project and I met a problem. I find out that some examples can not include the head for the support library in another example and vice virsa. For instance, the "tone" example can not include "dsplib.h" for the usage of fir() function. And "FIR" example can not include "dsk5510.h". the complier always report that the corrosponding file can not be opened....


how to use command line argument in CCS 3.1

Started by "Sundar S." in TMS320c55x13 years ago

I need to use command line arguments and i am working on CCS 3.0 Pl let me know for the documents details or any body of you have used...

I need to use command line arguments and i am working on CCS 3.0 Pl let me know for the documents details or any body of you have used command line arguments pl let me know at earliest. I tried with usual int main(argc,char*argv[]) but after linking the code i was not able to pass the arguments from command line.


Argument Passing Problem.

Started by Prakash Kamliya in TMS320c55x13 years ago 1 reply

We are facing one problem with CCS 3.1 and also with CCS 2.1 Argument passing is incorrect. We call 2 functions. GenCallPrgTone(x, y, z) ...

We are facing one problem with CCS 3.1 and also with CCS 2.1 Argument passing is incorrect. We call 2 functions. GenCallPrgTone(x, y, z) -> UMTG_genSignal(x) here the x, y and z arguments are passed in AR0, AR1 and T0 respectively, but it passes incorrect value of x to UMTG_genSignal function, instead it passes value of y ! code: GenCallPrgTones() { UMTG_genSiganl(genObj2-> fxn


C5502 CSL Module Support in cdb file

Started by salleehh in TMS320c55x15 years ago

Hi All My freinds>> I have a module of EVM5502 and I use CCS in my devlopment So, My CCS version is latest version from...

Hi All My freinds>> I have a module of EVM5502 and I use CCS in my devlopment So, My CCS version is latest version from TI Update Advisor v2.21 BUT, but the cdb files of c5502 not including any of CSL Module just a list of System......Input/Output


CCS scripting (perl) & CCS GEL "scripting" problems

Started by Dan in TMS320c55x15 years ago

Hi, my name is Dan Huff. I've been using Code Composer Studio and the TMS320VC5510 DSP for several years. I've developed ...

Hi, my name is Dan Huff. I've been using Code Composer Studio and the TMS320VC5510 DSP for several years. I've developed dsp/hardware-control applications for several different embedded C5510-based hardware boards, and a few support and test programs for that hardware. I'm fair