Using C5510 HPI as GPIO

Started by Rick Collins in TMS320c55x14 years ago 1 reply

It has been awhile since I have used the C55 family and I can't remember if they support using the HPI as GPIO if you are not using the HPI. I...

It has been awhile since I have used the C55 family and I can't remember if they support using the HPI as GPIO if you are not using the HPI. I seem to recall that some of the TI DSPs can do that, but I don't see anything in the docs that says the C5510 is capable of it. Anyone know for sure if the C5510 HPI can be used as GPIO?


Connecting DS80C410 to TMS320VC5509A using HPI port

Started by llurpol in TMS320c55x12 years ago 1 reply

DS80C410 is master.TMS320VC5509A is slave. Address Signals of DS80C410 was used as control signals. Data bus signals[7:0] of DS80C410 was...

DS80C410 is master.TMS320VC5509A is slave. Address Signals of DS80C410 was used as control signals. Data bus signals[7:0] of DS80C410 was connected to HPI data bus (HPI.HD). Address and data signals was transmit using HPI.HD when Host (DS80C410) access DSP. HPI port work at Multiplexed Mode(Address and data share one bus). The HPI.HAS# Signal(Address strobe signal) is Tied High in the Mul...


5509A in either HPI or EMIF mode

Started by ludovic44fr in TMS320c55x15 years ago 2 replies

Hi everyone, We are currently upgrading our product, going from 5410A to 5509A. I do need to use the EMIF to load my...

Hi everyone, We are currently upgrading our product, going from 5410A to 5509A. I do need to use the EMIF to load my code from flash, and i also need to use the HPI to communicate with the Host. The only problem, is that these 2 ports (EMIF and HPI)


Question on HPI bootup and switch to EMIF mode

Started by zhon...@senao.com in TMS320c55x12 years ago 5 replies

I have a question about EMIF/HPI mode in C5507. It is true that we can not use HPI and EMIF at the same time, but the question is Can we use...

I have a question about EMIF/HPI mode in C5507. It is true that we can not use HPI and EMIF at the same time, but the question is Can we use HPI mode to boot up DSP when power up and then switch to EMIF mode by the application code after that? Thanks


Re: Succeeded in read but failed in write from HOST to DSP through HPI

Started by ling...@yahoo.com.cn in TMS320c55x12 years ago

Lingbo- > > Which 55x DSP are you using? > > > > We always use multiplexed mode for HPI. However, for non-multiplexed...

Lingbo- > > Which 55x DSP are you using? > > > > We always use multiplexed mode for HPI. However, for non-multiplexed mode > > I think > > you still need to connect HCNTL1, which is not in your list above. Both > > HCNTL0 and > > HCNTL1 have to be connected to allow access to four (4) possible HPI > > registers: > > > > -HPIC > > -HPIA >


Re: Succeeded in read but failed in write from HOST to DSP through HPI

Started by Jeff Brower in TMS320c55x12 years ago

Lingbo- > Which 55x DSP are you using? > > We always use multiplexed mode for HPI. However, for non-multiplexed mode > I...

Lingbo- > Which 55x DSP are you using? > > We always use multiplexed mode for HPI. However, for non-multiplexed mode > I think > you still need to connect HCNTL1, which is not in your list above. Both > HCNTL0 and > HCNTL1 have to be connected to allow access to four (4) possible HPI > registers: > > -HPIC > -HPIA > -HPID no autoincreme


HPI question

Started by mayu in TMS320c55x16 years ago 1 reply

Hello everyone, I use Hpi port to boot DSP5510 and exchange data between host and 5510. It works OK. However, when I connected...

Hello everyone, I use Hpi port to boot DSP5510 and exchange data between host and 5510. It works OK. However, when I connected DSP with emulator through JTAG port and start CCS2.1 without running any programe, the host failed to write and read DSP through HPI port. But at


Bootloader code for HPI of C55x DSP

Started by nash...@yahoo.com in TMS320c55x13 years ago

Hi all, can anyone let me know where i can get Bootloader code for HPI? Pls do the needful Thanks in advance Nash

Hi all, can anyone let me know where i can get Bootloader code for HPI? Pls do the needful Thanks in advance Nash


C5509a EMIF/HPI

Started by aimo...@gmail.com in TMS320c55x13 years ago

Hello, I'm trying to change parallel bus to EMIF mode, but I don't know how to do it from source code. It goes to HPI mode when because of...

Hello, I'm trying to change parallel bus to EMIF mode, but I don't know how to do it from source code. It goes to HPI mode when because of BOOT3 (IO.0) is 0 during power up (bootloader uses serial EEPROM). I'm trying to write EBSR register (0x6c00) but it doesn't work. Can it be done dynamically (datasheet doesn't recommend that) and how? thanks, Janne


Re: [code-comp] CCS scripting (perl) & CCS GEL "scripting" problems

Started by Jeff Brower in TMS320c55x16 years ago

Dan- Just a general comment, but why are you using CCS/JTAG for production testing? Do you have a simple HPI connector on your...

Dan- Just a general comment, but why are you using CCS/JTAG for production testing? Do you have a simple HPI connector on your board? All of the full functional test groups we've worked with (Cisco, Sanmina, Nortel, etc) use HPI interface. JTAG tends to be slow, you hav


C5509A core(CPU domain) suspend problem(use HPI multiplexed boot)

Started by djj...@hxpsp.com in TMS320c55x10 years ago

Hi,Anyone can help? I'am debugging a hardware system based on 5509a chip and got a strange problem,it trouble me many days. My system use...

Hi,Anyone can help? I'am debugging a hardware system based on 5509a chip and got a strange problem,it trouble me many days. My system use HPI multiplexed boot mode(hard set the BOOTM[3..0]),the system clock use a outside OSC circuit of 20M. The host can access the DSP DARAM very stablely(I test it by writting the test code and then reading it back for comparison many times,and never found...


Re: C5509A core(CPU domain) suspend problem(use HPI multiplexed boot)

Started by Jeff Brower in TMS320c55x10 years ago

DJJ- > I'am debugging a hardware system based on 5509a chip and got a strange > problem,it trouble me many days. > > My system use HPI...

DJJ- > I'am debugging a hardware system based on 5509a chip and got a strange > problem,it trouble me many days. > > My system use HPI multiplexed boot mode(hard set the BOOTM[3..0]),the > system clock use a outside OSC circuit of 20M. > > The host can access the DSP DARAM very stablely(I test it by writting > the test code and then reading it back for comparison many times,and > neve


EMIF TO HPI

Started by gbon...@tiscali.it in TMS320c55x10 years ago 3 replies

In a master /slave application with two 5502-300Mhz, the master (via EMIF) read slave memory (throw its HPI). To speed-up the access, the EMIF is...

In a master /slave application with two 5502-300Mhz, the master (via EMIF) read slave memory (throw its HPI). To speed-up the access, the EMIF is configured in 32bit access to avoid double read. But the throughput is not very high, each read cycle (done by the master from DMA) is 300n. The EMIF configuration is : TA=0, read setup=1, read strobe=3, read hold=1. If I reduce read strobe to 2 it doesn...


Succeeded in read but failed in write from HOST to DSP through HPI

Started by lingboly in TMS320c55x12 years ago 1 reply

Succeeded in read but failed in write from HOST(S3C2410) to DSP through HPI in Nonmultiplexed Mode. My connection is : HCS

Succeeded in read but failed in write from HOST(S3C2410) to DSP through HPI in Nonmultiplexed Mode. My connection is : HCS


Re: Succeeded in read but failed in write from HOST to DSP through HPI

Started by Jeff Brower in TMS320c55x12 years ago

Ling Bo Ly- > Succeeded in read but failed in write from HOST(S3C2410) to DSP > through HPI in Nonmultiplexed Mode. > My connection is...

Ling Bo Ly- > Succeeded in read but failed in write from HOST(S3C2410) to DSP > through HPI in Nonmultiplexed Mode. > My connection is : > HCS HR/W HMOED HCNTL0 HDS1 HDS2 HBE0 HBE1 HRDY=> IOCHRDY > HINT=> nIRQ > HD[15..0] DATA[15..0] > HA[19..0] RESET_MODE SO BASE address of HPID read


Interfacing TMS320VC5509A with PC

Started by mvpr...@gmail.com in TMS320c55x9 years ago 11 replies

Hello, I need to interface TMS320VC5509A with PC.... 5509A offers SPI,HPI,USB communication,but i need RS232 communication, since it...

Hello, I need to interface TMS320VC5509A with PC.... 5509A offers SPI,HPI,USB communication,but i need RS232 communication, since it will be easy for read/write operation using VB6.... Is there any specific interface IC to convert avaliable protocol to RS232 protocol?.... Waiting for your reply.... Regards Pradeep


Re: 5509A in either HPI or EMIF mode

Started by dileepan_c in TMS320c55x15 years ago 3 replies

hi, hope you know the problem with the C5501/5502 emif wherin it will always do a 32 bit asynchronous memory read...

hi, hope you know the problem with the C5501/5502 emif wherin it will always do a 32 bit asynchronous memory read irrespective of your mtype configuration. further, the asynchronous memory writes works as expected.refer the latest emif document spru621e for details.


Interrupt HPI in non-multiplex mode

Started by LindaHYang in TMS320c55x17 years ago

Hi there, I am trying to find out how to interrupt DSP Host-Port-Interface in non-multiplex mode for C542x DSPs. HPIC is...

Hi there, I am trying to find out how to interrupt DSP Host-Port-Interface in non-multiplex mode for C542x DSPs. HPIC is memory-mapped to address 2C. In non-multiplex mode, is it possible to read and/or write to HPIC or there is some other way to cause interrupt?


Intermittent HPI bootloading of c5502 using MSP430F149

Started by mxpotluri in TMS320c55x12 years ago 3 replies

Hello, In our project we are using the TMS320C5502 DSP processor which is bootloaded using the hostport interface (8bit multiplexed mode)...

Hello, In our project we are using the TMS320C5502 DSP processor which is bootloaded using the hostport interface (8bit multiplexed mode) with the MSP430F149 as the host. The problem we have is the bootloader is intermittent. Whenever the bootloader fails on connecting the jtag and observing the contents of the DSP memory locations. We can observe that certain memory locations have di...


Re: Re: Succeeded in read but failed in write from HOST to DSP through HPI

Started by Jeff Brower in TMS320c55x12 years ago

Lingbo- > TI does not give a suggested value of RS to configurate the boot mode,just > said"BOOTM[2:0] are sampled following reset to...

Lingbo- > TI does not give a suggested value of RS to configurate the boot mode,just > said"BOOTM[2:0] are sampled following reset to configure the boot > mode for the DSP." > Now,1K Resistors are used instead of 10Ks to pull up/down BOOTM[2:0]. > And one change has happened that the internal memory can not be read anymore when the simulator is connected to the DSP. > Disconnecting the sim