Forums

UART

Started by sriram K September 15, 2003
Hi all
I need to a transfer a file(*.txt)over the UART from
the blackfin board.
I have seen the sample assembly program but it is
highly confusing.can anyone plz send me a sample C
code of one such(any tranfers via UART).
Thanks in advance
Sriram

__________________________________



Hi
I have an example assembly code for BF532 so i
think u can use it.

.global _UART_Tx_Configuration;
_UART_Tx_Configuration:

P0.H = (DMA7_PERIPHERAL_MAP >> 16) & 0xFFFF;
P0.L = DMA7_PERIPHERAL_MAP & 0xFFFF;
R0 = 0x7000;
W[P0] = R0;
ssync;

P0.H = (UART_GCTL >> 16) & 0xFFFF;
P0.L = UART_GCTL & 0xFFFF;
R0=0x1;
W[P0] = R0.L;
ssync;

P0.H = (UART_LCR >> 16) & 0xFFFF;
P0.L = UART_LCR & 0xFFFF;
R0 = 0x0000;
W[P0] = R0.L;
ssync;

P0.H = (UART_IER >> 16) & 0xFFFF;
P0.L = UART_IER & 0xFFFF;
R0 = 0x0003;
W[P0] = R0.L;
ssync;

P0.H = (DMA7_CONFIG >> 16) & 0xFFFF;
P0.L = DMA7_CONFIG & 0xFFFF;
R0 = 0x1000;
W[P0] = R0;
ssync;

R0.H = _uart_tx_buffer; /* Address of character
array*/
R0.L = _uart_tx_buffer;

P0.H = (DMA7_START_ADDR >> 16) & 0xFFFF;
P0.L = DMA7_START_ADDR & 0xFFFF;
[P0] = R0;
ssync;

P0.H = (DMA7_X_COUNT >> 16) & 0xFFFF;
P0.L = DMA7_X_COUNT & 0xFFFF;
R0 = 0x80; /* Count to be loaded */
W[P0] = R0.L;
ssync;

P0.H = (DMA7_X_MODIFY >> 16) & 0xFFFF;
P0.L = DMA7_X_MODIFY & 0xFFFF;
R0 = 0x1;
W[P0] = R0.L;
ssync;

P0.H = (UART_LCR >> 16) & 0xFFFF;
P0.L = UART_LCR & 0xFFFF;
R0 = 0x0080; /*8 bits, 1 stop bit,no parity*/
W[P0] = R0.L;
ssync;

P0.H = (UART_DLL >> 16) & 0xFFFF;
P0.L = UART_DLL & 0xFFFF;
R0 = 0x28b; /* Here system Clock is at 100Mhz*/
W[P0] = R0.L;
ssync;

P0.H = (UART_DLH >> 16) & 0xFFFF;
P0.L = UART_DLH & 0xFFFF;
R0=R0>>8;
W[P0] = R0.L;
ssync;

P0.H = (UART_LCR >> 16) & 0xFFFF;
P0.L = UART_LCR & 0xFFFF;
R0 = 0x0003;
W[P0] = R0.L;
ssync;

P0.H = (DMA7_CONFIG >> 16) & 0xFFFF;
P0.L = DMA7_CONFIG & 0xFFFF;
R0 = 0x1001;
W[P0] = R0;
ssync;

RTS;

--- sriram K <> wrote:
> Hi all
> I need to a transfer a file(*.txt)over the UART from
> the blackfin board.
> I have seen the sample assembly program but it is
> highly confusing.can anyone plz send me a sample C
> code of one such(any tranfers via UART).
> Thanks in advance
> Sriram
>
> __________________________________ >
> _____________________________________
> Note: If you do a simple "reply" with your email
> client, only the author of this message will receive
> your answer. You need to do a "reply all" if you
> want your answer to be distributed to the entire
> group.
>
> _____________________________________
> About this discussion group:
>
> To Join: Send an email to > To Post: Send an email to
>
> To Leave: Send an email to > Archives: http://groups.yahoo.com/group/adsp
>
> Other Groups: http://www.dsprelated.com/groups.php3 > ">http://docs.yahoo.com/info/terms/


__________________________________




but I may as well ask anyways.

If you have ever worked with ARM DSP, what development
tools would you recommend?

Thanks.

hh_ca


Hi all
I have a very simple Q....I trying to run the UART
Hyperterminal program that has come along with the 533
Blackfin Kit.....I was able to start a hyperterminal
program..Perform Autobaud detection......but when i
type any cahrecter or string and want to see the
charecter echo
back ....i do not get the echo
(I am typing the string followed by the ENTER key on
the keyboard...)but i do not see the echo....

Thanks in advance
Regards
Sriram __________________________________


Hi Sriram,

I do not know about the Blackfin kit, but I know little bit
about the Hyperterminal.
If your question is regarding "How to see the characters that we
typed on Hyperterminal", please proceed further.
Otherwise, ignore the rest of this mail.

To get the echo on Hyperterminal, you need to enable the "Echo
typed character locally".
After configuring the Hyperterminal go to
File->Properties->settings->ASCII Setup
In that enable the check box, Echo typed character locally.

Regards,
Sarat

-----Original Message-----
From: sriram K [mailto:]
Sent: Friday, September 26, 2003 10:22 AM
To:
Subject: [adsp] UART Hi all
I have a very simple Q....I trying to run the UART
Hyperterminal program that has come along with the 533
Blackfin Kit.....I was able to start a hyperterminal
program..Perform Autobaud detection......but when i
type any cahrecter or string and want to see the
charecter echo
back ....i do not get the echo
(I am typing the string followed by the ENTER key on
the keyboard...)but i do not see the echo....

Thanks in advance
Regards
Sriram __________________________________ _____________________________________
Note: If you do a simple "reply" with your email client, only the author
of this message will receive your answer. You need to do a "reply all"
if you want your answer to be distributed to the entire group.

_____________________________________
About this discussion group:

To Join: Send an email to

To Post: Send an email to

To Leave: Send an email to

Archives: http://groups.yahoo.com/group/adsp

Other Groups: http://www.dsprelated.com/groups.php3 ">http://docs.yahoo.com/info/terms/




hi
I need to disable the echo mode in the
hyperterminal.....which i did because the adsp has to
echo the charecter back......
Thnaks
Regards
sriram

--- Sarat Jampani <> wrote:
> Hi Sriram,
>
> I do not know about the Blackfin kit, but I know
> little bit
> about the Hyperterminal.
> If your question is regarding "How to see the
> characters that we
> typed on Hyperterminal", please proceed further.
> Otherwise, ignore the rest of this mail.
>
> To get the echo on Hyperterminal, you need to
> enable the "Echo
> typed character locally".
> After configuring the Hyperterminal go to
> File->Properties->settings->ASCII Setup
> In that enable the check box, Echo typed character
> locally.
>
> Regards,
> Sarat
>
> -----Original Message-----
> From: sriram K [mailto:]
> Sent: Friday, September 26, 2003 10:22 AM
> To:
> Subject: [adsp] UART > Hi all
> I have a very simple Q....I trying to run the UART
> Hyperterminal program that has come along with the
> 533
> Blackfin Kit.....I was able to start a hyperterminal
> program..Perform Autobaud detection......but when i
> type any cahrecter or string and want to see the
> charecter echo
> back ....i do not get the echo
> (I am typing the string followed by the ENTER key on
> the keyboard...)but i do not see the echo....
>
> Thanks in advance
> Regards
> Sriram > __________________________________ >
> _____________________________________
> Note: If you do a simple "reply" with your email
> client, only the author
> of this message will receive your answer. You need
> to do a "reply all"
> if you want your answer to be distributed to the
> entire group.
>
> _____________________________________
> About this discussion group:
>
> To Join: Send an email to > To Post: Send an email to
>
> To Leave: Send an email to > Archives: http://groups.yahoo.com/group/adsp
>
> Other Groups: http://www.dsprelated.com/groups.php3 > ">http://docs.yahoo.com/info/terms/ >
>
> _____________________________________
> Note: If you do a simple "reply" with your email
> client, only the author of this message will receive
> your answer. You need to do a "reply all" if you
> want your answer to be distributed to the entire
> group.
>
> _____________________________________
> About this discussion group:
>
> To Join: Send an email to > To Post: Send an email to
>
> To Leave: Send an email to > Archives: http://groups.yahoo.com/group/adsp
>
> Other Groups: http://www.dsprelated.com/groups.php3 > ">http://docs.yahoo.com/info/terms/


__________________________________