Fw: Re CCS ==> Target DSP load error

Started by Richard Williams June 16, 2013
---------- Forwarded Message -----------
From: "Richard Williams"
To: shiva bagherzadeh
Sent: Sun, 16 Jun 2013 03:27:15 -0700
Subject: Re CCS ==> Target DSP load error


according to the error messages, your configuration file is trying to place some
of the executable (or .const or .data, etc) into an area of the DSP memory map
that does not contain either FLASH or RAM.

You have not displayed your source nor configuration nor which DSP you are using.

Perhaps your configuration of the CCS is not correct. The configuration of the
CCS must be the same as the actual target DSP.
(or at the very least, the memory map must be the same.)

Are you using a start-up macro in the CCS to map the target DSP memory,
registers, etc? If not, then you may need to add such a macro.

So, for me to be helpful, I will need (at least) the following details:
-- which DSP
-- CCS configuration details
-- CCS linker control file
-- .map file - (this will be the most important file for debugging this)

The first two (above) will orient me to the DSP and what the CCS thinks is the DSP.
The last two (above) will tell me exactly what is being placed at the suspect
address and why.

I may also need the CCS start-up macro (not the target DSP start-up macro) contents.

Since I do not know which DSP your using, I cannot check the details, but it
could be your code is being loaded in L1 or L2 cache.
(under normal circumstances, the code must be copied to the cache area(s) at run
time, after the code configures the cache area boundaries, etc.)

R. Williams

---------- Original Message -----------
From: shiva bagherzadeh
To: "r...@lewiscounty.com"
Sent: Sun, 16 Jun 2013 01:49:15 -0700 (PDT)
Subject: N/A

> hi
> my problem about the libraries has been solved due
> to your advices, now when i run the program, there is an error about
> the memory as follows:   Loader: One or more sections of your program falls
> into a memory region that is not writable.  These regions will not
> actually be written to the target.  Check your linker configuration and/or
> memory map.
> Error:   Memory Map Error: READ access by CPU to address 0x2f060,
> which is RESERVED in Hardware. 
> Trouble running Target CPU:   Memory Map Error: READ access by CPU to
> address 0x2f0a0, which is RESERVED in Hardware. 
> i want to know what should i start to do to
> remove this error.
> thank u.
------- End of Original Message -------
------- End of Forwarded Message -------