Forums

McASP in 6713

Started by Bernhard 'Gustl' Bauer May 2, 2005
Hi,

I changed from 6713 rev. 1.1 to 6713B rev. 2.0. Now McASP receiver won't
work anymore.

After reset it receive a randow number of words (via EDMA) and the
stops. The only indication I have is a RSYNCERR. Does anybody know if
such an error can cause the receiver to halt? According to spru041 it
should continue running.

I've check the signals. They seam to be ok. If I reset McASP it starts
running again for a short time. Clearing the RSYNCERR has no effect.

Any hints will be appreciated.

Gustl


Hi,

I have some new input on this.

As long as AFSR and ACLKR are generated from the same clocksource as
CLKIN all works fine. But when I switch to a different clocksource the
error occurs. I supose the state machine crashes. If I reset the state
machine it works again for a short time.

gustl

Bernhard 'Gustl' Bauer wrote:
> Hi,
>
> I changed from 6713 rev. 1.1 to 6713B rev. 2.0. Now McASP receiver won't
> work anymore.
>
> After reset it receive a randow number of words (via EDMA) and the
> stops. The only indication I have is a RSYNCERR. Does anybody know if
> such an error can cause the receiver to halt? According to spru041 it
> should continue running.
>
> I've check the signals. They seam to be ok. If I reset McASP it starts
> running again for a short time. Clearing the RSYNCERR has no effect.
>
> Any hints will be appreciated.
>
> Gustl >




I receive data contuniously. McASP is connected to a Crystal CS8416
which handles AES/EBU input. I don't have an overrun error condition! I
have a RSYNCERR which is caused by an late or early AFSR.

I read the data by EDMA, so an overrun cannot happen.

Ashfaq Khan wrote:

> Do clear the Receive Enable bit if your recieving process ends. The
> problem iftenly happened when you dont make a queue or dont read data
> when it comes and if it overloaed .. so its be recommended when you
> receive the data dont remain Serial RX port opened just disable it >
> Bernhard 'Gustl' Bauer <gustl@gust...> wrote:
>
> Hi,
>
> I changed from 6713 rev. 1.1 to 6713B rev. 2.0. Now McASP receiver
> won't
> work anymore.
>
> After reset it receive a randow number of words (via EDMA) and the
> stops. The only indication I have is a RSYNCERR. Does anybody know if
> such an error can cause the receiver to halt? According to spru041 it
> should continue running.
>
> I've check the signals. They seam to be ok. If I reset McASP it starts
> running again for a short time. Clearing the RSYNCERR has no effect.
>
> Any hints will be appreciated.
>
> Gustl >
>
> Yahoo! Messenger
> <http://uk.messenger.yahoo.com>" target="_blank" rel="nofollow">http://uk.rd.yahoo.com/mail/tagline_messenger/*http://uk.messenger.yahoo.com>
> - Communicate instantly..."Ping" your friends today! Download Messenger
> Now
> <http://uk.messenger.yahoo.com/download/index.html>" target="_blank" rel="nofollow">http://uk.rd.yahoo.com/mail/tagline_messenger/*http://uk.messenger.yahoo.com/download/index.html>
>