Forums

Code Composer Simulator

Started by Impatiens Publications March 29, 2000
Greetings:

I am using the code-composer version 1.1, and attempting to use the
simulator without a target.

Specifically, I am trying to get through the tutorial. The
documentation recommends using a target, but says I may follow the
instructrions in chapters 2 and 4 of the tutorial without requiring a
target. The problem is that with loading the program to the simulator.
After compiling, loading the program (File->Load Program) results in
nine-ten error dialog boxes. The specific error for each dialog box is:

Data Verification failed at XXXX

Where XXX is the hex address of the failure.

My question is how may I configure code composer to run the compiled
tutorial code without having a target attached?

Any help is greatly appreiated.

Sincerely,

Byron Miller




Byron,

I noticed that the Simulator doesn't support the full memory range, only
selected areas of the memory space. I haven't checked it in the manual,
so I might be wrong on that. But trying to access a memory location that is not
supported gives the mentioned error message.
So you have to check if the memory setup of the tutorial examples are correct
for the simulator too and not just for the EVM board.

Best regards,

Paul Kamphuis ------
Paul Kamphuis
DSP engineer

www.jive.nl
Joint Institute for VLBI in Europe Phone : +31-521-596535
Radiosterrenwacht Dwingeloo or : +31-521-596500
Postbus 2 Fax :
+31-521-597332
7990 AA DWINGELOO, the Netherlands

PLEASE NOTE: In the near future "" may be the
only proper address, old addresses in your aliases could fail. >>> Impatiens Publications <> 03/29/00 12:57pm >>>
Greetings:

I am using the code-composer version 1.1, and attempting to use the
simulator without a target.

Specifically, I am trying to get through the tutorial. The
documentation recommends using a target, but says I may follow the
instructrions in chapters 2 and 4 of the tutorial without requiring a
target. The problem is that with loading the program to the simulator.
After compiling, loading the program (File->Load Program) results in
nine-ten error dialog boxes. The specific error for each dialog box is:

Data Verification failed at XXXX

Where XXX is the hex address of the failure.

My question is how may I configure code composer to run the compiled
tutorial code without having a target attached?

Any help is greatly appreiated.

Sincerely,

Byron Miller To Join:
To Post:
To Leave:
Archives: http://www.egroups.com/group/code-comp
More Groups: http://www.dsprelated.com Special Offer-Earn 300 Points from MyPoints.com for trying @Backup
Get automatic protection and access to your important computer files.
Install today:
http://click.egroups.com/1/2344/3/_/10680/_/954349530/

-- 20 megs of disk space in your group's Document Vault
-- http://www.egroups.com/docvault/code-comp/?m=1



Please try like follow:
click Option/Memory Map
change the program memory to be: 0x0000-0xffff   EXRAM
change the data memory to be :    0x0000-0x7fff  RAM
                                                     0x8000-0xffff   EXRAM
may you lucky,

fishcow
 

Paul Kamphuis wrote:

Byron,

I noticed that the Simulator doesn't support the full memory range, only selected areas of the memory space. I haven't checked it in the manual,
so I might be wrong on that. But trying to access a memory location that is not supported gives the mentioned error message.
So you have to check if the memory setup of the tutorial examples are correct for the simulator too and not just for the EVM board.

Best regards,

Paul Kamphuis

------
Paul Kamphuis
DSP engineer

k...@jive.nl                                     www.jive.nl
Joint Institute for VLBI in Europe              Phone : +31-521-596535
Radiosterrenwacht Dwingeloo                     or    : +31-521-596500
Postbus 2                                                   Fax   : +31-521-597332
7990 AA DWINGELOO, the Netherlands

PLEASE NOTE: In the near future "k...@jive.nl" may be the
             only proper address, old addresses in your aliases could fail.

>>> Impatiens Publications <i...@isd.net> 03/29/00 12:57pm >>>
Greetings:

I am using the code-composer version 1.1, and attempting to use the
simulator without a target.

Specifically, I am trying to get through the tutorial.  The
documentation recommends using a target, but says I may follow the
instructrions in chapters 2 and 4 of the tutorial without requiring a
target.  The problem is that with loading the program to the simulator.
After compiling, loading the program (File->Load Program) results in
nine-ten error dialog boxes.  The specific error for each dialog box is:

Data Verification failed at XXXX

Where XXX is the hex address of the failure.

My question is how may I configure code composer to run the compiled
tutorial code without having a target attached?

Any help is greatly appreiated.

Sincerely,

Byron Miller


To Join:  c...@egroups.com
To Post:  c...@egroups.com
To Leave: c...@egroups.com
Archives: http://www.egroups.com/group/code-comp
More Groups: http://www.dsprelated.com


Special Offer-Earn 300 Points from MyPoints.com for trying @Backup
Get automatic protection and access to your important computer files.
Install today:
http://click.egroups.com/1/2344/3/_/10680/_/954349530/

-- 20 megs of disk space in your group's Document Vault
-- http://www.egroups.com/docvault/code-comp/?m=1


To Join:  c...@egroups.com

To Post:  c...@egroups.com

To Leave: c...@egroups.com

Archives: http://www.egroups.com/group/code-comp

More Groups: http://www.dsprelated.com


Good friends, school spirit, hair-dos you'd like to forget.
Classmates.com has them all. And with 4.4 million alumni already
registered, there's a good chance you'll find your friends here:
http://click.egroups.com/1/2622/3/_/10680/_/954419686/

-- Talk to your group with your own voice!
-- http://www.egroups.com/VoiceChatPage?listName=code-comp&m=1



Dear fishcow,

You are right, this is the way to tell code composer which memory is used and
with what function. However the simulator in Code Composer v4.10 for the C3x/4x
( i.e. the Code Composer Studio look a like), doesn't support every memory
location in the memory map. For example if I change the memory to 0x00000000 -
0xfffffffff RAM, so the entire memory range is read/write RAM. Then viewing the
memory map at e.g. location 0xffff0000 reports BAD at all locations and it also
doesn't allow you to change the value at that location. While viewing location
0x80000000 shows a usable memory region.

This means (unless I am doing something wrong) that only some specific memory
regions are allowed to be used in the C3x/4x version 4.10 of the Code Composer.

Kind regards

Paul Kamphuis ------
Paul Kamphuis
DSP engineer

www.jive.nl
Joint Institute for VLBI in Europe Phone : +31-521-596535
Radiosterrenwacht Dwingeloo or : +31-521-596500
Postbus 2 Fax :
+31-521-597332
7990 AA DWINGELOO, the Netherlands

PLEASE NOTE: In the near future "" may be the
only proper address, old addresses in your aliases could fail. >>> clear_bright <> 03/31/00 03:12am >>>
Please try like follow:
click Option/Memory Map
change the program memory to be: 0x0000-0xffff EXRAM
change the data memory to be : 0x0000-0x7fff RAM
0x8000-0xffff EXRAM
may you lucky,

fishcow