Linker accepts only 7 library search directories - what to do ?

Started by greg...@yahoo.com January 18, 2007
I'm using CCS 2.2. I split my project into several libraries to achieve better modularity. But afterwards linker started to report an error about too manu -i options used ( library search directories ).
I was able to solve the problem but I run into other problem - my specific cmd file ( linker command file ) didn't work correctly any more. I specify in it, in which memory to put specific sections from specific libraries. Linker reports sections from my libraries are not found and place them in default memory ( internal RAM ) which is too small. The result is I cannot build the application.

I tried these solutions:
1. following help, I created A_DIR environement variable pointing to directories containing libraries --> sections not found
2. I copy in the pre-build step all libraries into one directory. This directory is one and only "library search" directory --> sections not found
3. I created one library containing all libraries --> undocumented error about missing symbol information appeared
4. I specified full paths to the libraries in the linker command file and I didn't include them in project file at all --> OK !

I found the solution, but it is not good for software developement, because I have to rewrite the file each time I want to switch between debug and release versions.

Did anybody solved this problem of inconsistent linker behaviour ?