Forums

problems connecting MSK2812 with CCS

Started by gioax October 23, 2008
Hi everybody
I have the Technosoft MSK2812 board, that is equipped with the TMS320F2812
DSP
I would like to program my board with the CCS 3.0.
First of all I tried toi program the board with the RS232 port, but then I
read that it wasn't
possible because the CCS has no emulators for the RS232, its'true???
So I tried to program my board using the JTAG port J5 with the XDS510PP
PLUS JTAG EMULATOR
that I have connected with the parallel port. 
I selected the F2812 PP emulator into the setup of the CCS but when I
tried to "connect"
i had the following error message:

Error connecting to the target:
Error 0x80000200/-2092
Fatal Error during: OCS, 
Device driver: Emulation Connection Loss Detected on Target CPU.
It is recommended to RESET EMULATOR.  This will disconnect each 
target from the emulator.  The targets should then be power cycled
or hard reset followed by an emureset and reconnect to each target.


Sequence ID: 0
Error Code: -2092
Error Class: 0x80000200
I/O Port = 378

Board Name: F2812 PP Emulator
Cpu Name: cpu_0

Abort:		Close Code Composer Studio.
Retry:		Try to connect to the target again.
Cancel:		Remain disconnected from the target
Diagnostic:	Run diagnostic utility.

as if I haven't connected anything to my PC.

I supplyed the board with 5V and i have seen a strange thing. 
If i connect before the JTAG and then I give 5V to the board,
the board has not supply and the led of the board is off.
However also giving power before to the board and then connecting
the JTAG EMULATOR I can't connect to the board...

Which is the problem? Can we use this emulator with that board??
At the beginning I thought that the JTAG was damaged, but with another
board
it works well in CCS...
There is a problem with the connector of the board??

Can anyone help me in this?

Thank you.