Forums

No live Message Log in CCS for C6xxx

Started by Wolfgang May 24, 2004
Hello,

I don't get a "live" feedback from CCS using
LOG_printf(&trace, "Hello world.");
Only if the program is stopped the message log is updated.
When it's counter reaches 63 it's stopped.
Also the CPU load graph does not work.

        Has anybody suggestions why ?

                                    THX, Wolfgang

P.S.: 
- Host Refresh Rates are 1 sec.
- Real time analysis is enabled.
- Live Data (from target) checked.
- Continuous Mode checked.
- IDL_loop is executed.
Any other suggestions ?
"Wolfgang" <never@nowhere.com> wrote in message
news:c8smmi$qrh$01$1@news.t-online.com...
> Hello, > > I don't get a "live" feedback from CCS using > LOG_printf(&trace, "Hello world."); > Only if the program is stopped the message log is updated. > When it's counter reaches 63 it's stopped. > Also the CPU load graph does not work. > > Has anybody suggestions why ? > > THX, Wolfgang > > P.S.: > - Host Refresh Rates are 1 sec. > - Real time analysis is enabled. > - Live Data (from target) checked. > - Continuous Mode checked. > - IDL_loop is executed. > Any other suggestions ?
It sounds like you don't have RTDX enabled. In your cdb file go to Input/Output -> RTDX. Right-click and select properties and then click the "Enable RTDX" box. Also right-click on HST and make sure the Host Link Type is set to RTDX. Brad
Hello Brad,

RTDX - Real-Time Data Exchange Settings were set to True.
HST - Host Channel Manager's "Host Link Type" was not set to RTDX.
I changed this setting but unfortunately nothing changed.
I get the Text in the Log-Window but only if I stop the program.
And CPU Load Graph is still empty.
Never the less many thanks for your hints.
I guess I missed one of these check boxes but I don't know where to search.

What's allso interesting is that the log graph works only to 64 entries.

                                                                    Regards, Wolfgang

> It sounds like you don't have RTDX enabled. In your cdb file go to > Input/Output -> RTDX. Right-click and select properties and then click the > "Enable RTDX" box. Also right-click on HST and make sure the Host Link Type > is set to RTDX. > > Brad
"Brad Griffis" <bradgriffis@hotmail.com> wrote in message news:<Aawsc.11964$eH1.6267425@newssvr28.news.prodigy.com>...
> "Wolfgang" <never@nowhere.com> wrote in message > news:c8smmi$qrh$01$1@news.t-online.com... > > Hello, > > > > I don't get a "live" feedback from CCS using > > LOG_printf(&trace, "Hello world."); > > Only if the program is stopped the message log is updated. > > When it's counter reaches 63 it's stopped. > > Also the CPU load graph does not work. > > > > Has anybody suggestions why ? > > > > THX, Wolfgang > > > > P.S.: > > - Host Refresh Rates are 1 sec. > > - Real time analysis is enabled. > > - Live Data (from target) checked. > > - Continuous Mode checked. > > - IDL_loop is executed. > > Any other suggestions ? > > It sounds like you don't have RTDX enabled. In your cdb file go to > Input/Output -> RTDX. Right-click and select properties and then click the > "Enable RTDX" box. Also right-click on HST and make sure the Host Link Type > is set to RTDX. > > Brad
Same to me also :-( . I have done what Brad mentioned, but still no luck... something must be missing. tnk
Under scheduling look under the IDL functions.  Make sure there are a few
there.  I believe that one of them is called dataPump or something similar.
Those IDL functions are what actually do the transfer.

Have you created your own IDL function?  If so, you need to yield control so
that the RTDX IDL functions can run.  Otherwise the RTDX functions get
starved and data doesn't get transferred.

The size of that data buffer can be changed in BIOS cdb file.  I don't have
time to look right now at exactly where, but you can probably find it.  The
sizes are multiples of 2.  I know you can make it at least 1024 maybe a
little bigger.  Maybe making the buffer bigger will be enough to help.

Brad

"Wolfgang" <never@nowhere.com> wrote in message
news:c8upca$gu2$02$1@news.t-online.com...
> Hello Brad, > > RTDX - Real-Time Data Exchange Settings were set to True. > HST - Host Channel Manager's "Host Link Type" was not set to RTDX. > I changed this setting but unfortunately nothing changed. > I get the Text in the Log-Window but only if I stop the program. > And CPU Load Graph is still empty. > Never the less many thanks for your hints. > I guess I missed one of these check boxes but I don't know where to
search.
> > What's allso interesting is that the log graph works only to 64 entries. > >
Regards, Wolfgang
> > > It sounds like you don't have RTDX enabled. In your cdb file go to > > Input/Output -> RTDX. Right-click and select properties and then click
the
> > "Enable RTDX" box. Also right-click on HST and make sure the Host Link
Type
> > is set to RTDX. > > > > Brad >
Thanks Brad,

> Under scheduling look under the IDL functions. Make sure there are a few
IDL_cpuLoad, LNK_dataPump, RTA_dispatcher
> Have you created your own IDL function?
No, I'm just starting with DSP/BIOS. Implemented it and ...
> The size of that data buffer can be changed in BIOS cdb file.
I played with it. Changed it to 8192Byte. This speeds down CCS. And as I've only one periodic function called every 4sec. (Scheduling - PRD - TriggerPeriodicEvent) making one printf 512Byte should be o.k. The communication to PC seems not to be the problem. I changed "Instrumentation-LOG-Event Log Manager - trace logtype" to circular and now (when stopping the program) the message log Window shows more than 64 messages. I suggest that a "update setting" in CCS is missing. But the only thing I found is in Features of RTA Control Panel the "Host Refresh Rates" which I all set to 1 sec. Still looking for a list like "all you need for CPU Load" but did not find anything in Help or Online. Thanks for spending time giving suggestions, Wolfgang
I've noticed that this problem can be resolved by re-setting the RTDX port
configuration in CCS3.x. Go to Tools:RTDX:Configuration Control. In the
RTDX control panel under the Port Configuration tab, select the mode as
NONE then back to RTDX then hit Apply or OK. Even though the port config
may be set to RTDX already, just swapping the setting from none then back
to RTDX gets things working.

Christian


		
This message was sent using the Comp.DSP web interface on
www.DSPRelated.com