strange CPU error

Started by JimJ...@msn.com February 26, 2008
Hello to everyone,

I have created a simple project that samples a sinus wave and then it calculates the FFT of the sampling data. I am using a C54x card but what I describe happens in the simulation (I have not tested it in real mode with the card yet.)

The program was working but I had forgotten to bit reverse the samples for the FFT. Whether I use the cbrev function (which by the way does not seam to work) or a bit reverse source code I wrote which works I get the following message when I run the program.

"Trouble running Target CPU: Error number -2600 Error address 3"

If I try to run again after I get this message I get this new one:

"Trouble running Target CPU: Access to unmapped memory at Addr:0x2dffff Page:0"

I have not done anything strange with the memory and I use arrays of 128 elements which do not take such a great space in the memory.
By the way it is worth mentioning that I get no error messages in the compile stage. Just the above ones when I run it.

I will be grateful if you can help me on this one.
Check Out Industry's First Single-Chip, Multi-Format, Real-Time HD Video Transcoding Solution for Commercial & Consumer End Equipment: www.ti.com/dm6467