Forums

56F803EVM. flash_over_jtag problem

Started by e_e_f_j January 28, 2005

Hello
Im try to work with my 56F803EVM to download it my software with
flash_over_jtag but i can not do it, flash_over_jtag say:
"Target chip refused to enter Debug mode!"
here the full info from flash_over_jtag :

DSP56F800 Flash loader. Compiled on Dec 10 2002, 17:53:51.
version Epsilon 0.1
(c) Motorola 2001 - 2002, MCSL
Partial Copyright 2000-2002, Zloba Alexander
I/O port driver started
JTAG IR path length: 4
JTAG DR path length: 1 (BYPASS)
IDCode status: 0x9
Jtag ID: 0x11f2501d
Debug Request status: 0x9
Enable OnCE status: 0x9, polls left: 10
Enable OnCE status: 0x9, polls left: 9
Enable OnCE status: 0x9, polls left: 8
Enable OnCE status: 0x9, polls left: 7
Enable OnCE status: 0x9, polls left: 6
Enable OnCE status: 0x9, polls left: 5
Enable OnCE status: 0x9, polls left: 4
Enable OnCE status: 0x9, polls left: 3
Enable OnCE status: 0x9, polls left: 2
Enable OnCE status: 0x9, polls left: 1
Enable OnCE status: 0x9, polls left: 0
Target chip refused to enter Debug mode!

I just see the installation Guide from my EVM and i think that all
are plug in ok.

thanks.
Best regards.
Exell E. Franklin J.



Hello,
Thank you Rick Corey.
I have the 56F803EVM. about a one year and half,
i can not use never code warrior when i buy EVM, they send me
a SDK 2.3.5 and a code warrior 4.0 and the suport wsa over...
Now i can try to use this.
I know that the cable is good but i am to change it.
i`m goin to send a message to freescale about de JTAG bug...

Tanks
Best regards
sorry by my english.


Hi

I think that Metrowerks offers a free version of the most recent
CodeWarrior, that will let you compile code up to 8K words, or 16K words,
something like that. Try this for the Metrowerks website and grab an eval
copy of 56800:

http://www.metrowerks.com/MW/download/default.asp#evals That might let you test your cables and setup, by downloading from
CodeWarrior.

The problem might be electrical, or it might be with flash_over_jtag setup.

The 803 chip on the eval board might have old silicon on it - do check the
errata sheet for that revision of the chip. We had some ancient revs, going
back to Rev A and Rev B.

You might search the archives of this list from suggestions about
flash_over_jtag.

Archives: http://www.dsprelated.com/groups/motoroladsp/1.php

Good luck!

Rick Corey
-----Original Message-----
From: e_e_f_j [mailto:]
Sent: Friday, January 28, 2005 4:23 PM
To:
Subject: [motoroladsp] 56F803EVM. flash_over_jtag problem

Hello,
Thank you Rick Corey.
I have the 56F803EVM. about a one year and half,
i can not use never code warrior when i buy EVM, they send me
a SDK 2.3.5 and a code warrior 4.0 and the suport wsa over...
Now i can try to use this.
I know that the cable is good but i am to change it.
i`m goin to send a message to freescale about de JTAG bug...

Tanks
Best regards
sorry by my english.




thank you Georg Bende, and all.
My chips has the following ref:
XC56F803BU80
ZKAA0123
and the board have the following ref
RE10103B REV A
S/N M8072-01 0001 21007581 1172
I send a question to freescale the says that they think chip is ok..
but im wrinting a re..
I check the the jumper "JG2" and it is disable.
JG8 is 2-3
JG4 int boot is jumpered
JG5 open.
JG3 1-2
JG9 jumpered
a question LED8 must be on when i pulg the electrical source, or
wheni use the DSP?
thank to all.
Best regards.
E.E.F.J.




Hello.
Thank you.
Where can i get the flash_over_jtag Gamma 0.2 ver?
E.E.F.J.