Forums

Symphony Studio 56720 Simulator -- simulator command script file

Started by "joh...@ymail.com" February 5, 2009
Hi,

Thank you for your replies.

I can't get this to work. I'm using the example in APR35 section
2.2.1. It runs correctly reading and writing to memory but not to the
I/O files. I've modified the simulator script according to appendix B
of the DSP Studio User Guide (I think I've read it correctly??) and
tried all sorts of combinations.

So I think the problem is with the simulator command script file.

In Symphony Studio I've right clicked on the project and added a file
called SimCmd.txt to the project. The SimCmd.txt file contains the
simulator script.

Then specified the SimCmd.txt file in external tools 56720 Simulator
Simulator command file.

In Symphony Studio I've right clicked on the project and added the
infile.dat and outfile.dat files to the project.

If I delete the SimCmd.txt file the simulator won't run and displays a
"Variable reference non-existent resource:" error message, so the
simulator is finding the script file.

The simulator script file:
core.0 reset s
core.0 input off
core.0 output off
core.0 load FileIOTryout.cld
core.0 input #1 simdatain infile.dat -rh
core.0 output #1 simdataout outfile.dat -rh -o
core.0 break eof
core.0 go

I've tried with and without the core.0 prefix to the instructions.

I've also tried just

core.0 input #1 x:$0 infile.dat -rh
core.0 output #1 x:$0 outfile.dat -rh -o

Have I understood (from the DSP Studio User Guide Appendix B):
"Each line of the command file must follow this format:
. "

Has anyone got this to work?

I'm probably making a silly mistake but can't see the wood for the trees.

Thanks again for your help.

Regards,

John.