Forums

Memory map setting in CCS

Started by torgeirjakobsen September 12, 2003
Hi

I have a problem with the emulation through Code Composer Studio. So,
far I have used the simulator when developing my software for the
TMS320VC5510 DSP. Now I want to emulate to eliminate the last few
bugs that I have in my program. I use the XDS510PP Plus emulator, and
it seems to work ok against the DSP on our hardware.
The loading of my program is not correct. Writing to the registers in
io-space does not work, this actually changes the same address in
data memory.
I think the problem is that I have to specify a memory map to CCS.
This was not necessary in the simulator. I have made a gel-file which
corresponds to my memory settings in my project linker command file,
but I get an error message when loading the program.

Error message:
Load failed. A section of your program falls into a memory region
that is not writable. Check your linker configuration and/or memory
map.

The error comes when CCS tries to load the .const section, but it
also seems to give the same error on the .cinit section. I also get
the same error message when using the same gel-file in the simulator.
I have made all memory writable in the gel-file. So, I do not
understand why I get this message.

Has anyone experienced the same problem ?